View Issue Details

IDCategoryLast Update
0006942bugs2016-08-13 19:58
ReporterzettberlinAssigned Topaul 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntu StudioOS Version15.10
Product Version5.0-pre 
Fixed in Version 
Summary0006942: Ardour hangs at startup with gtk Clearlooks unexpexted identifier 'reliefstyle'
DescriptionStarting ardour5 as build from git today yields:

/usr/share/themes/Clearlooks/gtk-2.0/gtkrc:77: error: unexpected identifier 'reliefstyle', expected character '}'

The respective section of the gtkrc-file looks perfectly normal.

        engine "clearlooks" {
                colorize_scrollbar = TRUE
                #this seems to trouble ardour5
                reliefstyle = 1
                menubarstyle = 2
                toolbarstyle = 1
                animation = FALSE
                radius = 3.0
                style = GUMMY

                # Set a hint to disable backward compatibility fallbacks.
                hint = "use-hints"
        }

ardour5 repeats that error infinitely, in one occasion it tried to start after approx 2 minutes showing the error. In this one occasion the start-screen (select project) looked normal.
Steps To ReproduceTry start ardour5 in a terminal.
Additional InformationI have not changed the ui_config file, deleting this file or config or instant.xml in $HOME/.config/ardour5 does not change anything.
TagsNo tags attached.

Relationships

related to 0005605 resolvedx42 Hangs while starting at loading UI config files 

Activities

paul

2016-08-05 20:16

administrator   ~0018344

This is caused by using your own build, which still loads system GTK RC files.

You can't stop this without rebuilding your own GTK stack. We do this for the build stacks that we use on ardour.org.

The problem will not manifest with a nightly build (or should not).

zettberlin

2016-08-06 10:25

reporter   ~0018345

Ok, thanks for the clearification.
I found a workaround also: changing the GTK-Theme to Industrial made the trouble disappear.
I consider this solved....

paul

2016-08-13 19:58

administrator   ~0018361

see notes.

Issue History

Date Modified Username Field Change
2016-08-05 09:59 zettberlin New Issue
2016-08-05 20:16 paul Note Added: 0018344
2016-08-05 20:24 x42 Relationship added related to 0005605
2016-08-06 10:25 zettberlin Note Added: 0018345
2016-08-13 19:58 paul Note Added: 0018361
2016-08-13 19:58 paul Status new => resolved
2016-08-13 19:58 paul Resolution open => fixed
2016-08-13 19:58 paul Assigned To => paul