View Issue Details

IDProjectCategoryView StatusLast Update
0006937ardourbugspublic2019-01-01 12:06
ReporterYruama_Lairba Assigned Topaul  
PrioritynormalSeveritycrashReproducibilityhave not tried
Status assignedResolutionopen 
Platformx86_64OSdebianOS Versiontesting (jessie)
Product Version4.7 
Summary0006937: Crash or no UI with LV2 Calf plugin
DescriptionArdour Crash when trying to use some Calf LV2 Plugin, and is unable to open UI of others.
Steps To ReproduceCrashing example : try to insert Calf Deesser, it will crash with this error in the terminal :

ardour-4.7.0: lv2gui.cpp :313 : void* gui_instantiate(const _LV2UI_Descriptor*, const char*, const char*, LV2UI_Write_Function, LV2UI_Controller, void**, const LV2_Feature* const*): l'assertion « xml » a échoué.

Unable to open UI example : try to insert Calf Crusher , it give the following error in the terminal when trying to open the UI :

suil error: Failed to instantiate UI <> in /usr/lib/lv2/calf.lv2/
Additional InformationArdour 4.7.0
"Cluster and Eno"
(built from revision 1:4.7~dfsg-1)
Intel 64-bit

calf-plugins 0.0.60-1~bpo8+1
TagsNo tags attached.



2016-08-13 20:01

administrator   ~0018363

This is a report on a Linx-distribution's (debian, probably) version of Ardour.

We do not support these builds.

We do not believe this is an issue with Ardour obtained from, so please try one one (demo copies are available), and either confirm that it is a real problem, or mark the bug closed.


2016-08-14 13:49

reporter   ~0018367

I tried the official demo of Ardour 5.0.5 (rev 5.0-5-gfc27ef) intel 64 bits and the problem still here.
I also tried different versions of ardour4 and calf that was working before, but the problem still here, so i think the problem come from a librairy on my system. Unfortunally i don't know who to address the problem or how to identify more preciselly the problem.

Strangely, calf plugin doesn't seems to have any problmes with other software like qtractor or jalv.gtk


2019-01-01 12:06

reporter   ~0020563

Still a problem in 2019, albeit with Ubuntu Studio 18.10 version of Ardour

"Working Backwards"
(rev 1:5.12.0-3)
Intel 64-bit

see for calf reported issue

Issue History

Date Modified Username Field Change
2016-08-03 18:10 Yruama_Lairba New Issue
2016-08-13 20:01 paul Note Added: 0018363
2016-08-13 20:01 paul Assigned To => paul
2016-08-13 20:01 paul Status new => feedback
2016-08-14 13:49 Yruama_Lairba Note Added: 0018367
2016-08-14 13:49 Yruama_Lairba Status feedback => assigned
2019-01-01 12:06 chippyash Note Added: 0020563