View Issue Details

IDCategoryLast Update
0006916features2020-04-19 20:18
ReporterLeatuspenguinAssigned Topaul 
ReproducibilityN/A 
Status closedResolutionfixed 
Product Version 
Fixed in Version 
Summary0006916: Plugin manager rearrangement idea to make better use of space
DescriptionIt would be nice if the plugin list was taller so you could see more plugins at a time. This could be easily achieved by moving the 'plugins to be connected' section to the side. The full width of the 'plugins to be connected' section is never used. Moving it to the side would also have the nice side effect of making it taller, which is more important than it being wide.

This would allow for the plugin list to be significantly taller, without making the window too much bigger. See attached mockup.
TagsNo tags attached.

Activities

Leatuspenguin

2016-07-04 17:41

reporter  

plugin_manager.png (111,531 bytes)
plugin_manager.png (111,531 bytes)

paul

2016-07-06 22:26

administrator   ~0018279

It is always a huge pleasure to read your suggestions, and sometimes even better to implement them. One day we're going to do a release consisting of nothing but your ideas!

it wasn't possible to get quite as much vertical space as in your suggestion, but d7caa89 implements most of this idea.

Leatuspenguin

2016-07-06 23:10

reporter   ~0018285

Paul, you mentioned implementing some of my suggestions before. It's great to hear that some of them are still on the cards. I understand yours/ardours priorities so it's nice to hear that you still remember them :)

The image was just a mockup but you got it damn close, considering toolkit restraints. I think it makes much better use of the space. I always felt there was wasted space in the plugin manager but it only clicked with me the other day of a better way to lay it out. Thank you very much for implementing :)

system

2020-04-19 20:18

developer   ~0023625

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-07-04 17:41 Leatuspenguin New Issue
2016-07-04 17:41 Leatuspenguin File Added: plugin_manager.png
2016-07-06 22:26 paul Note Added: 0018279
2016-07-06 22:26 paul Status new => resolved
2016-07-06 22:26 paul Resolution open => fixed
2016-07-06 22:26 paul Assigned To => paul
2016-07-06 23:10 Leatuspenguin Note Added: 0018285
2020-04-19 20:18 system Note Added: 0023625
2020-04-19 20:18 system Status resolved => closed