View Issue Details

IDCategoryLast Update
0006904bugs2017-07-06 06:54
ReporterLeatuspenguinAssigned Topaul 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformLinuxOSDebianOS VersionJessie
Product Version5.0-pre 
Fixed in Version 
Summary0006904: Mixer List panel dividers can be dragged to the point where they can't be grabbed again
DescriptionThe issue with the divider not being able to be grabbed again primarily relates to resizing of the 'Strips' section in the mixer list but there are also other quirks with overlapping of buttons in the mixer list panel.

See the linked video below where the 'Strips' divider is moved. It is moved downwards and overlaps the 'Add tracks/busses' button. If it is let go at this point, it can no longer be grabbed.

rev 5.0-pre0-290-gb5a134d

Video link - https://sendvid.com/6t7ps2wb
TagsNo tags attached.

Activities

paul

2016-07-06 22:31

administrator   ~0018283

I believe this is fixed now.

Leatuspenguin

2016-07-06 23:20

reporter   ~0018288

Still an issue here, but this is using a local build. Will try tomorrow with a nightly build and report back.

paul

2016-07-06 23:36

administrator   ~0018289

Ah, those buttons. Yes, this is unsolved, and possibly unsolvable. It happened with the GtkPaned and it happens with my new Paned. It seems to be bad behaviour by the buttons, as much as anything else.

I was imagining issues with the left/right panes when they got close to the edges of the mixer/editor.

Leatuspenguin

2016-07-07 07:40

reporter   ~0018290

The button issue is not the main problem. If you collapse the 'show strips' pane, you can't expand it again (21 seconds into the video). The only way to get the pane back is to delete the config file.


Grab the panel divider above 'show strips' and move it downwards until that pane is collapsed and no longer visible, then let go of the mouse. Now when you try to expand the pane again, it is impossible to grab the divider to expand it.

Issue History

Date Modified Username Field Change
2016-06-22 11:59 Leatuspenguin New Issue
2016-07-06 22:31 paul Note Added: 0018283
2016-07-06 22:31 paul Assigned To => paul
2016-07-06 22:31 paul Status new => feedback
2016-07-06 23:20 Leatuspenguin Note Added: 0018288
2016-07-06 23:20 Leatuspenguin Status feedback => assigned
2016-07-06 23:36 paul Note Added: 0018289
2016-07-07 07:40 Leatuspenguin Note Added: 0018290
2017-07-06 06:54 Leatuspenguin Status assigned => resolved
2017-07-06 06:54 Leatuspenguin Resolution open => fixed