View Issue Details

IDCategoryLast Update
0006870bugs2020-04-19 20:18
ReporteroswaldmAssigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformIntel x86 64OSUbuntu StudioOS Version14.04 LTS
Product Version4.7 
Fixed in Version 
Summary0006870: Moving regions creates large numbers of regions
DescriptionGrabbing a region and dragging it around (only moving) creates a lot of regions, like if the regions are used as a paintbrush.

Since a large number of new regions is created, this makes Ardour practically unusable to do edits on regions.

Ardour 4.7.935
"Cluster and Eno"
(rev 4.7-951-ge48da9d)
Intel 64-bit

But I have also observed this on previous versions.


See attached video as a demonstration.

Steps To Reproduce - Switch with "G" to grab mode (or smart mode)
 - Drag-Move a region

Region is used as a paintbrush.
TagsNo tags attached.

Activities

oswaldm

2016-05-04 14:04

reporter  

ArdourError.mp4 (998,891 bytes)

paul

2016-05-05 13:24

administrator   ~0018172

You'll need to provide a more precise recipe, starting from an empty, new session.

I have never observed this behaviour.

oswaldm

2016-05-05 15:57

reporter   ~0018175

Hi Paul,

I played around with it and it is quite easy to reproduce in my system:

- Empty session
- Add Audio track
- Record something (in my case guitar->Line6 Helix SPDIF -> Saffire Pro -> Ardour) with punch range
- Switch to "No Grid" (either menu or shortcut)
- Go into Grab mode with "G"
- Move region

So it seems to be linked to the No Grid option.

oswaldm

2016-05-05 15:59

reporter  

Ardour_Region_Error.png (201,575 bytes)
Ardour_Region_Error.png (201,575 bytes)

oswaldm

2016-05-05 16:00

reporter   ~0018176

I also attached screenshot with the second track showing this behaviour. The screenshot shows the stacked mode, which shows quite a bit of layers after moving the region.

oswaldm

2016-05-05 16:02

reporter   ~0018177

Also in the terminal I get a lot of messages like this:

a - start after end: 22050, 22049
a - start after end: 22050, 22049
a - start after end: 22050, 22049
a - start after end: 22050, 22049
a - start after end: 22050, 22049
b - start after end: 22050, 22049
a - start after end: 22050, 22049
a - start after end: 22050, 22049
a - start after end: 22050, 22049
a - start after end: 22050, 22049
b - start after end: 22050, 22049
a - start after end: 22050, 22049

colinf

2016-05-09 15:39

updater   ~0018185

I saw this happen once (with yesterday's git master HEAD): I don't recall what led up to it happening, and I was recording a band at the time, so I wasn't able to investigate any further, but I can add the observation that quitting and re-starting Ardour made the problem go away, and it didn't then recur.

As for the "start after end" messages, mea culpa, but probably a red herring: that's some debugging output I put in a while back that I'm fairly sure isn't related to this issue. I should probably just remove it.

aFunkyBass

2016-05-16 00:30

reporter   ~0018196

It happened to me several times. I wasn't able to track steps that lead to this problem though.

Undoing, it removes all the unwanted new regions from track, but not from region list. Closing session and repoening it, fixes the problem.

Version 4.7 Ubuntustudio 14.04

zettberlin

2016-08-18 15:17

reporter   ~0018406

I have the same here with the official A5.05 package.
Undoing the results with opening the Edit-Menu shows a nessage like: Undo brush.

So this brush mode is a intended thing?

zettberlin

2016-08-18 15:24

reporter   ~0018407

There are some references of a brush mode in Ardours sources also:

ardour5/gtk2_ardour/SAE-de-nokeypad.bindings.in:; (gtk_accel_path "<Actions>/Editor/brush-at-mouse" "F3")

ardour5/gtk2_ardour/editor_drag.cc: _editor->begin_reversible_command (Operations::drag_region_brush);

ardour5/gtk2_ardour/editor_mouse.cc:Editor::mouse_brush_insert_region (RegionView* rv, framepos_t pos)


and more...

so this brush mode is intended. But how do I disable it or switch back to normal?

And it should never ever be activated automatically...

paul

2016-08-18 16:13

administrator   ~0018410

in the current version of ardour, it happens only when dragging with the "b" key pressed.

zettberlin

2016-08-18 20:11

reporter   ~0018413

OK, I cannot remember to have b pressed, anyway, once that mode is activated is there a way to return to normal?

paul

2016-08-18 20:55

administrator   ~0018414

it isn't a mode. Its a special kind of drag. It is over when the drag is over.

zettberlin

2016-08-18 22:04

reporter   ~0018415

That would be nice, but actually it is *not* over, it seems to turn into a mode.
Once I press B while dragging, the next drag is brushing too, *whithout* pressing b again. And it stays that way until I close/open Ardour...

paul

2016-08-19 12:34

administrator   ~0018419

Fixed in git.

As a workaround, if you move the mouse out of the editor window and back, that will also clear the incorrect "b-is-down" state.

Sorry for the error.

zettberlin

2016-08-19 13:09

reporter   ~0018421

Compiled new from git: the problem is gone.

BTW: if one is prepared this brush mode is a remarkable feature! Can be much nicer than using duplication for making loops ;-)

Unfortunately the workaround does not work for me in Ardour 5.05... no matter, where I put or move the mouse: the false b-down does not seem to go away...

paul

2016-08-25 02:02

administrator   ~0018478

see notes. key release event did not clear Gtkmm2ext::Keyboard state.

system

2020-04-19 20:18

developer   ~0023615

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-05-04 14:04 oswaldm New Issue
2016-05-04 14:04 oswaldm File Added: ArdourError.mp4
2016-05-05 13:24 paul Note Added: 0018172
2016-05-05 15:57 oswaldm Note Added: 0018175
2016-05-05 15:59 oswaldm File Added: Ardour_Region_Error.png
2016-05-05 16:00 oswaldm Note Added: 0018176
2016-05-05 16:02 oswaldm Note Added: 0018177
2016-05-09 15:39 colinf Note Added: 0018185
2016-05-16 00:30 aFunkyBass Note Added: 0018196
2016-08-18 15:17 zettberlin Note Added: 0018406
2016-08-18 15:24 zettberlin Note Added: 0018407
2016-08-18 16:13 paul Note Added: 0018410
2016-08-18 20:11 zettberlin Note Added: 0018413
2016-08-18 20:55 paul Note Added: 0018414
2016-08-18 22:04 zettberlin Note Added: 0018415
2016-08-19 12:34 paul Note Added: 0018419
2016-08-19 13:09 zettberlin Note Added: 0018421
2016-08-25 02:02 paul Note Added: 0018478
2016-08-25 02:02 paul Status new => resolved
2016-08-25 02:02 paul Resolution open => fixed
2016-08-25 02:02 paul Assigned To => paul
2020-04-19 20:18 system Note Added: 0023615
2020-04-19 20:18 system Status resolved => closed