View Issue Details

IDCategoryLast Update
0006839bugs2020-04-19 20:18
ReporterovenwerksAssigned Toovenwerks 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformIntel 64bitOSubuntustudio OS Version14.04
Product Version4.7 
Fixed in Version 
Summary0006839: Sending OSC gaindB values between -193 and -319 shows wrong in Ardour's GUI
DescriptionSending:
oscsend localhost 3819 /ardour/routes/gaindB if 2 -250
Ardour's GUI shows -135dB
oscsend localhost 3819 /ardour/routes/gaindB if 2 -251
gives -134dB

-193 already gives -192.3
-194 -> -191.3
-195 -> -190.3
-300 -> -85.3 (very possibly audible if this is the conversion to gain)
-310 -> -75.3
-318 -> -67.3
-319 -> inf
TagsNo tags attached.

Activities

ovenwerks

2016-03-27 19:14

reporter   ~0018080

Forgot to add, this seems to be in the display end, not the dB to gain end.
tested by adding osc to track followed by to amps set at gain*4. Use OSC to send -67 -> audio audible/shows on meter. Use OSC to send -318 -> no audio, but GUI shows -67.3dB

ovenwerks

2016-03-28 00:48

reporter   ~0018081

git commit 3eb5f76edb70 makes all OSC gaindB values below -192 = inf (gain=0)

system

2020-04-19 20:18

developer   ~0023608

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-03-27 19:11 ovenwerks New Issue
2016-03-27 19:14 ovenwerks Note Added: 0018080
2016-03-28 00:48 ovenwerks Note Added: 0018081
2016-03-28 00:48 ovenwerks Status new => resolved
2016-03-28 00:48 ovenwerks Resolution open => fixed
2016-03-28 00:48 ovenwerks Assigned To => ovenwerks
2020-04-19 20:18 system Note Added: 0023608
2020-04-19 20:18 system Status resolved => closed