View Issue Details

IDCategoryLast Update
0006834bugs2020-04-19 20:18
Reporterjohne53Assigned Tojohne53 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformPCOSWindowsOS VersionWin 8.1
Product Version 
Fixed in Version 
Summary0006834: Text case mismatch (upper case / lower case) when reading key bindings
DescriptionDiscovered on Windows but probably affects all platforms...

The file "ardour.keys" contains various categories, such as:-

<Bindings name="global">
<Bindings name="editor">
<Bindings name="mixer">
<Bindings name="step-editing"> // <-- note this is hyphenated

Notice that the above are all in lower case text. However, when we search for them at various places in the code, our searches all seem to be capitalized - e.g.

Bindings::get_bindings(X_("Global"), global_actions)
Bindings::get_bindings(X_("Editor"), myactions)
Bindings::get_bindings(X_("Mixer"), myactions)
Bindings::get_bindings(X_("Step Editing"), myactions) // <-- note this one isn't hyphenated

So AFAICT the bindings aren't getting set up correctly from 'ardour.keys'
TagsNo tags attached.

Activities

johne53

2017-02-02 10:49

reporter   ~0019329

It seems like this got fixed at some point (not sure when exactly...)

system

2020-04-19 20:18

developer   ~0023607

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-03-25 14:46 johne53 New Issue
2017-02-02 10:49 johne53 Note Added: 0019329
2017-02-02 10:49 johne53 Status new => resolved
2017-02-02 10:49 johne53 Resolution open => fixed
2017-02-02 10:49 johne53 Assigned To => johne53
2020-04-19 20:18 system Note Added: 0023607
2020-04-19 20:18 system Status resolved => closed