View Issue Details

IDCategoryLast Update
0006780bugs2020-04-19 20:17
ReporterchickenskAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformLenovo X200OSManjaro LinuxOS Version3.18.26-1
Product Version4.6 
Fixed in Version 
Summary0006780: export dialog hangs controls
Descriptionwhen export in progress and opening export format list, after export finished, ardour closes export dialog and controls hangs

no problems closing ardour and reopening the session after

proposed solution is not autoclosing export dialog after export
Steps To Reproducepress export button -> open format list -> wait until export finished
TagsNo tags attached.

Activities

x42

2016-02-21 00:21

administrator   ~0017978

Last edited: 2016-02-21 00:21

View 2 revisions

Good catch.

It's not that easy :) The dialog holds various shared pointer references, closing the dialog is what actually releases those and flushes the file to disk.

A better solution is to make the format editor (and other actions) unavailable while Export is ongoing.

x42

2016-02-27 11:54

administrator   ~0018020

fixed in Ardour 4.7-237-gd95f2e9

system

2020-04-19 20:17

developer   ~0023589

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-02-20 23:39 chickensk New Issue
2016-02-21 00:21 x42 Note Added: 0017978
2016-02-21 00:21 x42 Note Edited: 0017978 View Revisions
2016-02-27 11:54 x42 Note Added: 0018020
2016-02-27 11:54 x42 Status new => resolved
2016-02-27 11:54 x42 Resolution open => fixed
2016-02-27 11:54 x42 Assigned To => x42
2020-04-19 20:17 system Note Added: 0023589
2020-04-19 20:17 system Status resolved => closed