View Issue Details

IDCategoryLast Update
0006746bugs2016-02-11 20:43
ReporteroswaldmAssigned Totimbyr 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformIntel x64OSUbuntu StudioOS Version14.04
Product Version 
Fixed in Version4.7 
Summary0006746: Crash on loading session
DescriptionArdour crashes on loading a session (an assertion fires)

Version: git checkout f315c0910da38420c4025e7be79d79f88720b9c0
Kernel: Linux 3.13.0-76-lowlatency 0000120-Ubuntu SMP PREEMPT x86_64

Attached is a backtrace of the crash.
Steps To ReproduceCrashes always on loading a specific session.
Additional InformationDon't know if this is relevant: session uses a Carla Rack as LV2 with some Windows VST plugins inside. It also uses quite some busses.
TagsNo tags attached.

Activities

oswaldm

2016-01-21 20:18

reporter  

Ardour_Crash_bug_report.txt (4,623 bytes)
ardour-4.6.96: ../libs/ardour/buffer_set.cc:250: ARDOUR::Buffer& ARDOUR::BufferSet::get(ARDOUR::DataType, size_t): Assertion `i < _available.get(type)' failed.

Program received signal SIGABRT, Aborted.
[Switching to Thread 0x7fff8e4d2700 (LWP 7674)]
0x00007ffff05d1cc9 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
56	../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
(gdb) Did not receive ping message from server for 30 secs, closing...
bt
#0  0x00007ffff05d1cc9 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1  0x00007ffff05d50d8 in __GI_abort () at abort.c:89
#2  0x00007ffff05cab86 in __assert_fail_base (fmt=0x7ffff071b830 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0x7ffff6cfc160 "i < _available.get(type)", 
    file=file@entry=0x7ffff6cfbfc8 "../libs/ardour/buffer_set.cc", line=line@entry=250, 
    function=function@entry=0x7ffff6cfc580 <ARDOUR::BufferSet::get(ARDOUR::DataType, unsigned long)::__PRETTY_FUNCTION__> "ARDOUR::Buffer& ARDOUR::BufferSet::get(ARDOUR::DataType, size_t)") at assert.c:92
#3  0x00007ffff05cac32 in __GI___assert_fail (assertion=0x7ffff6cfc160 "i < _available.get(type)", file=0x7ffff6cfbfc8 "../libs/ardour/buffer_set.cc", line=250, 
    function=0x7ffff6cfc580 <ARDOUR::BufferSet::get(ARDOUR::DataType, unsigned long)::__PRETTY_FUNCTION__> "ARDOUR::Buffer& ARDOUR::BufferSet::get(ARDOUR::DataType, size_t)") at assert.c:101
#4  0x00007ffff68c45bf in ARDOUR::BufferSet::get (this=0x19bd520, type=..., i=16) at ../libs/ardour/buffer_set.cc:250
#5  0x00007ffff6a899ca in ARDOUR::BufferSet::iterator_base<ARDOUR::BufferSet, ARDOUR::AudioBuffer>::operator* (this=0x7fff8e4d16b0) at /home/oswald/Projects/ardour/libs/ardour/ardour/buffer_set.h:144
#6  0x00007ffff6a87c2f in ARDOUR::MonitorProcessor::run (this=0x5242610, bufs=..., nframes=1024) at ../libs/ardour/monitor_processor.cc:332
#7  0x00007ffff6b4a7a2 in ARDOUR::Route::process_output_buffers (this=0x8f6d430, bufs=..., start_frame=0, end_frame=1024, nframes=1024, declick=0, gain_automation_ok=true) at ../libs/ardour/route.cc:628
#8  0x00007ffff6b4b6c1 in ARDOUR::Route::passthru (this=0x8f6d430, bufs=..., start_frame=0, end_frame=1024, nframes=1024, declick=0) at ../libs/ardour/route.cc:773
#9  0x00007ffff6b5bdce in ARDOUR::Route::no_roll (this=0x8f6d430, nframes=1024, start_frame=0, end_frame=1024, session_state_changing=true) at ../libs/ardour/route.cc:3560
#10 0x00007ffff69af4e8 in ARDOUR::Graph::process_one_route (this=0x51aa4f0, route=0x8f6d430) at ../libs/ardour/graph.cc:584
#11 0x00007ffff69b4136 in ARDOUR::GraphNode::process (this=0x8f6d6d0) at ../libs/ardour/graphnode.cc:79
#12 0x00007ffff69add6a in ARDOUR::Graph::run_one (this=0x51aa4f0) at ../libs/ardour/graph.cc:400
#13 0x00007ffff69adf74 in ARDOUR::Graph::helper_thread (this=0x51aa4f0) at ../libs/ardour/graph.cc:418
#14 0x00007ffff69b3827 in boost::_mfi::mf0<void, ARDOUR::Graph>::operator() (this=0x7fff8e4d1c28, p=0x51aa4f0) at /usr/include/boost/bind/mem_fn_template.hpp:49
#15 0x00007ffff69b2f38 in boost::_bi::list1<boost::_bi::value<ARDOUR::Graph*> >::operator()<boost::_mfi::mf0<void, ARDOUR::Graph>, boost::_bi::list0> (this=0x7fff8e4d1c38, f=..., a=...) at /usr/include/boost/bind/bind.hpp:253
#16 0x00007ffff69b29b5 in boost::_bi::bind_t<void, boost::_mfi::mf0<void, ARDOUR::Graph>, boost::_bi::list1<boost::_bi::value<ARDOUR::Graph*> > >::operator() (this=0x7fff8e4d1c28) at /usr/include/boost/bind/bind_template.hpp:20
#17 0x00007ffff69b22eb in boost::detail::function::void_function_obj_invoker0<boost::_bi::bind_t<void, boost::_mfi::mf0<void, ARDOUR::Graph>, boost::_bi::list1<boost::_bi::value<ARDOUR::Graph*> > >, void>::invoke (function_obj_ptr=...)
    at /usr/include/boost/function/function_template.hpp:153
#18 0x0000000000626ea6 in boost::function0<void>::operator() (this=0x7fff8e4d1c20) at /usr/include/boost/function/function_template.hpp:767
#19 0x00007fffe0426581 in ARDOUR::JACKAudioBackend::_start_process_thread (arg=0xb1ccdd0) at ../libs/backends/jack/jack_audiobackend.cc:936
#20 0x00007ffff1c43182 in start_thread (arg=0x7fff8e4d2700) at pthread_create.c:312
#21 0x00007ffff069547d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111
(gdb) frame 4
#4  0x00007ffff68c45bf in ARDOUR::BufferSet::get (this=0x19bd520, type=..., i=16) at ../libs/ardour/buffer_set.cc:250
250		assert(i < _available.get(type));
(gdb) list
245	}
246	
247	Buffer&
248	BufferSet::get(DataType type, size_t i)
249	{
250		assert(i < _available.get(type));
251		return *_buffers[type][i];
252	}
253	
254	const Buffer&
(gdb) 

oswaldm

2016-02-01 19:58

reporter   ~0017862

Today I tried to edit the session file directly and removed the monitoring section and routes. With this, I could load the session (with warnings) and then save it back.

So obviously, the Monitoring section has some problems somehow. Also see issue 6758 (http://tracker.ardour.org/view.php?id=6758)

timbyr

2016-02-11 03:56

developer   ~0017906

There have been some fixes related to the monitoring section, can you please re-test your session with recent/nightly build to see if this issue is now resolved.

oswaldm

2016-02-11 19:18

reporter   ~0017914

The session now loads again, so this seems to be fixed. As for the other issue (6758), this is still there.

Issue History

Date Modified Username Field Change
2016-01-21 20:18 oswaldm New Issue
2016-01-21 20:18 oswaldm File Added: Ardour_Crash_bug_report.txt
2016-02-01 19:58 oswaldm Note Added: 0017862
2016-02-11 03:56 timbyr Note Added: 0017906
2016-02-11 19:18 oswaldm Note Added: 0017914
2016-02-11 20:43 timbyr Status new => resolved
2016-02-11 20:43 timbyr Fixed in Version => 4.7
2016-02-11 20:43 timbyr Resolution open => fixed
2016-02-11 20:43 timbyr Assigned To => timbyr