View Issue Details

IDCategoryLast Update
0000067features2020-04-21 15:13
Reporterv2Assigned Topaul 
ReproducibilityN/A 
Status closedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000067: Fades for loops
DescriptionApart from automation, there seems to be no way to get gain fades for the end of a loop.

Inside the loops, the region fade in & out envelopes work correctly, but if the song ends (=no regions left on any track while playing) where the looping track is at the middle of a region, the sound will just stop. This causes a click, because the wave will get cut to zero from whatever point the wave is at the end of the project.

This behaviour would be corrected by having gain fades, like regions have, for loops.

(This behaviour was experienced with 0.9beta5 aka Ardour/GTK 0.401.0 running with libardour 0.690.0)
TagsNo tags attached.

Activities

paul

2003-10-21 23:18

administrator   ~0000047

to be really honest, i am a bit dubious about per-track looping. i think it would be better accomplished by region duplication, which would then allow you to fade the last region. the current implementation is a bit of a crock.

we'd make it easy to loop till the end of the session. the extra step would be to first form the desired region in the track. then click on it, select duplicate and add "till end of session" as an option.

what do you think?

taybin

2003-10-22 15:14

administrator   ~0000053

I agree about per-track looping. I don't think it fits well with Ardour's purpose.

v2

2003-10-22 17:14

developer   ~0000056

I understand your concerns. Looping might not be the number 1 concern for Ardour, but it's still a feature that exists and works (even though it has a quite serious bug, see 0000066).

If you need to apply your resources to more important features/bugfixes, this problem could be fixed quite easily by applying a fixed fade out envelope for the track (the same defaults as for regions?) in the end of the project if the 'song' ends in the middle of a looped region.

Some people like to use loops instead of duplicates, and this click combined with bug 0000066 makes Ardour a very bad choice for anyone using the loop feature. It can give Ardour bad rep.

paul

2003-10-22 17:34

administrator   ~0000057

the problem is that i don't of any other DAW that provides per-track looping. its a rather odd feature that has several hard problems. the most obvious one is sync between the looped track and non-looped tracks. if you start the transport at
position N, where should the looped track start? its not as obvious as it appears. this is one reason i would prefer a region-fill op, pretty much like the mackie HDR has. the per track loop has a number of tricky design problems like this.

bug 66 is easy to fix, and i will do soon.

v2

2003-10-28 11:33

developer   ~0000113

How does this sound?

Loop regions.

- Loop parameters would be treated as information on how to create the loop. The loop regions themselves would not be taken into account in the transport (not played etc.).

- The loop parameters could behave like 'regions' so they could be placed on tracks, resized and moved. They wouldn't be per-track based, so you could have more than one loop per track.

- Loop regions would contain information on how long the loop should be, or where the loop should end.

- Loop regions could be rendered/unredered/re-rendered. Rendering would mean a kind of 'automated duplication', which would create regions according to the loop parameters (=copy the parts of the regions which are in the loop region).

- The created regions would be marked as 'created from this specific loop', and thus the loop could be unrendered, and re-rendered when the user wants to change the loop.

I haven't used Mackie HDRs, but I suspect this is very close to the region-fill Paul mentioned. The advantage here would be that the loop could be easily modified, no transport problems, and of course, multiple loops per track. Also, you could change a single part of the rendered loop without affecting the whole loop.

What do you think?

taybin

2003-10-28 14:17

administrator   ~0000116

I think this sounds like a topic for post-1.0 discussion. In the meantime, region duplication will fill some of these requirements.

paul

2020-04-19 20:47

administrator   ~0023814

Loop fades are now implemented for 6.0, although fade lengths are non-configurable.

Loop regions should be moved to a different bug report.

x42

2020-04-21 15:13

administrator   ~0023843

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2003-10-21 21:18 v2 New Issue
2003-10-21 23:18 paul Note Added: 0000047
2003-10-21 23:18 paul Status new => feedback
2003-10-22 15:14 taybin Note Added: 0000053
2003-10-22 17:14 v2 Note Added: 0000056
2003-10-22 17:34 paul Note Added: 0000057
2003-10-28 11:33 v2 Note Added: 0000113
2003-10-28 14:17 taybin Note Added: 0000116
2003-11-05 15:36 taybin Status feedback => acknowledged
2003-11-05 15:36 taybin Description Updated
2003-11-12 17:45 taybin Priority normal => low
2020-04-19 20:47 paul Assigned To => paul
2020-04-19 20:47 paul Status acknowledged => resolved
2020-04-19 20:47 paul Resolution open => fixed
2020-04-19 20:47 paul Note Added: 0023814
2020-04-21 15:13 x42 Note Added: 0023843
2020-04-21 15:13 x42 Status resolved => closed