View Issue Details

IDCategoryLast Update
0006540bugs2020-04-19 20:17
ReportermhartzelAssigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version4.1 
Fixed in Version 
Summary0006540: Undo should be disabled during recording
DescriptionArdour (4.0 - 4.2) allows the user to undo while recoroding is going on. This creates a confused state in the undo buffer.

Here is how to recreate the problem.

- Start up ardour and create a single track
- Record a short clip and move it on the timeline. (Moving is needed to enable the undo function).
- Record a second short clip.
- Record a third clip and press control + z while recording is still going on.

The second clip dissapears and you cannot get it back by any amount of undoing or redoing. The undo buffer is in confused state. Usually the clip can be dragged back from the clip window, but sometimes in complex sessions with hunderds of clips, the clip that is undone during recording dissapeared also from the clip list.
Tagsundo

Activities

timbyr

2015-09-29 01:19

developer   ~0017396

I can confirm this with master@b8ccf8ac Ardour nightly >= 4.2.450

mhartzel

2016-01-24 14:57

reporter   ~0017828

Still present on Ardour 4.6

mhartzel

2016-03-08 17:47

reporter   ~0018050

Still present on Ardour 4.7

mhartzel

2016-08-14 16:30

reporter   ~0018369

This annoying bug has been in Ardour about one year and it still exists in Ardour 5.0.5.

paul

2016-08-17 23:23

administrator   ~0018397

Fixed in git. 41cc35cf6e2 and e8427ee2cb

system

2020-04-19 20:17

developer   ~0023514

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2015-08-22 20:02 mhartzel New Issue
2015-09-29 01:19 timbyr Note Added: 0017396
2015-09-29 01:19 timbyr Status new => confirmed
2015-09-29 01:21 timbyr Tag Attached: undo
2016-01-24 14:57 mhartzel Note Added: 0017828
2016-03-08 17:47 mhartzel Note Added: 0018050
2016-08-14 16:30 mhartzel Note Added: 0018369
2016-08-17 23:23 paul Note Added: 0018397
2016-08-17 23:23 paul Status confirmed => resolved
2016-08-17 23:23 paul Resolution open => fixed
2016-08-17 23:23 paul Assigned To => paul
2020-04-19 20:17 system Note Added: 0023514
2020-04-19 20:17 system Status resolved => closed