View Issue Details

IDCategoryLast Update
0006497bugs2020-04-19 20:17
ReporterunfaAssigned Tox42 
Reproducibilityhave not tried 
Status closedResolutionfixed 
Product Version4.1 
Fixed in Version 
Summary0006497: Two playlists of the same name causing user confusion and random changes in the session
DescriptionI'm working on a big session (meterbridge screenshot included).

It happened that I had two tracks and each hada separate playlist, but both used the same name.

I guess that just like tracks, playlists should have unique name, because otherwise, how do you differentiate between them?

I think Ardour got confused by that ambiguity itself, and after some session reload I noticed that both tracks use the same playlist (moving a region in one moves the same region in the other for example).

I fixed the issue by renaming one of the playlists, and they are no more confused on session loading.
Additional InformationI created the tracks by dragging down two regions at once. Then I renamed both tracks using the same string. Ardour automatically adds a suffix if the track name already exists and I relied on that, however looks like once it didn't apply this logic to naming the playlists assigned to the renamed tracks.

I used this process a to, creating tens of tracks this way, and it only happened once. But still it was very confusing and unpleasant to deal with.
TagsNo tags attached.

Relationships

related to 0005681 closedx42 POTENTIAL DATA LOSS due to duplicate playlist reference after renaming tracks 

Activities

2015-08-04 15:23

 

session.png (50,953 bytes)
session.png (50,953 bytes)

x42

2016-11-28 11:21

administrator   ~0019082

Since Ardour 5.4-470-ge9eea8d one cannot create new playlists with the same name. Playlist names are unique

system

2020-04-19 20:17

developer   ~0023499

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2015-08-04 15:23 unfa New Issue
2015-08-04 15:23 unfa File Added: session.png
2015-08-19 20:06 nettings Relationship added related to 0005681
2016-11-28 11:21 x42 Note Added: 0019082
2016-11-28 11:21 x42 Status new => resolved
2016-11-28 11:21 x42 Resolution open => fixed
2016-11-28 11:21 x42 Assigned To => x42
2020-04-19 20:17 system Note Added: 0023499
2020-04-19 20:17 system Status resolved => closed