View Issue Details

IDCategoryLast Update
0006321features2020-03-30 18:25
ReporterOliverAssigned To 
ReproducibilityN/A 
Status closedResolutionfixed 
Product Version 
Fixed in Version 
Summary0006321: Copy/paste or drag/drop or tracks between audio applications
DescriptionMany audio programs already allow adding tracks by mouse drop and/or paste with external audio files (on Linux e.g. Ardour, Audacity, Melodyne in wine).

The work flow between such programs could be improved considerably if they would also allow track-based copying to the system clip board (or starting a drag), such that a track can be transferred to another program easily.

This would replace the following longer sequence

1. Export a track (e.g. to .wav) in program A to a file.
2. Import this file into program B by importing or drag/drop.

by a single copy/paste or drag/drop operation.

This is to suggest such a feature for Ardour. A similar request has been put forward to the Audacity team. Between these two I would find this of particular use because of the complementary approach of real-time and off-line effects.

For Ardour copying would probably trigger a pre-programmed 'export' of a given track. I understand that dragging might be not a good solution, here, because of the time delay in creating the audio data. A copy operation, though, could display a 'progress window', just as normal export does.
 
Regards, Oliver.
TagsNo tags attached.

Activities

Oliver

2020-03-30 18:25

reporter   ~0021111

Probably already since some time Ardour does allow dropping of an audio file to a track or to the region list (found out with Ardour 5.12). Additional 'pasting' of audio copied from somewhere else is maybe not so important.

I understand that the opposite direction, from Ardour, should be done with the various 'Export' functions, given the complexity of stating what exactly to copy.

Issue History

Date Modified Username Field Change
2015-05-13 14:25 Oliver New Issue
2020-03-30 18:25 Oliver Status new => closed
2020-03-30 18:25 Oliver Resolution open => fixed
2020-03-30 18:25 Oliver Note Added: 0021111