View Issue Details

IDCategoryLast Update
0006128bugs2020-04-19 20:17
ReporterbdpAssigned Tox42 
Reproducibilitysometimes 
Status closedResolutionfixed 
Product Version 
Fixed in Version 
Summary0006128: Changing from Overlaid to Stacked mode crashes ardour if track not tall enough
DescriptionIf a track contains many layers ardour sometimes crashes when you go from overlaid to stacked mode.

I think this occurs when the track height is set too small for ardour to sensibly draw all the layers in. I was able to stop the crash by expanding the track height loads.

I haven't checked this out properly yet as I'm in the middle of comping a vocal. But as soon as I get a chance I'll try and list the steps to reproduce it at least.

I'm using Debian's package at the moment (from About Window):
Ardour 3.5.403~dfsg-3
(built from revision 3.5.403~dfsg-3)

I can try any version you like if you like, I've been able to build reliably from git in the past and I'm sure I could manage again if it would help somebody.
TagsNo tags attached.

Activities

x42

2015-01-13 17:52

administrator   ~0016243

I just tried with 33 overlaid regions, smallest track height with Ardour 3.5.4286
Switch to layered mode -> no crash (it's a visual mess though, but that's not unexpected).

I'm pretty sure this only affects the old canvas 3.5.403 (or earlier).

There's no need to build from git if you don't want to: http://nightly.ardour.org/ offers nychthemeral builds.

x42

2015-01-13 17:52

administrator   ~0016244

please try with a later version

bdp

2016-03-10 15:42

reporter   ~0018060

Only just noticed this bug is still open. I've not experienced this particular crash for ages (I've been using later versions). This can probably be closed without any further investigation.

x42

2016-03-10 15:57

administrator   ~0018061

closed as per OP's request

system

2020-04-19 20:17

developer   ~0023375

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2015-01-11 21:28 bdp New Issue
2015-01-13 17:52 x42 Note Added: 0016243
2015-01-13 17:52 x42 Note Added: 0016244
2015-01-13 17:52 x42 Status new => feedback
2016-03-10 15:42 bdp Note Added: 0018060
2016-03-10 15:42 bdp Status feedback => new
2016-03-10 15:57 x42 Note Added: 0018061
2016-03-10 15:57 x42 Status new => resolved
2016-03-10 15:57 x42 Resolution open => fixed
2016-03-10 15:57 x42 Assigned To => x42
2020-04-19 20:17 system Note Added: 0023375
2020-04-19 20:17 system Status resolved => closed