View Issue Details

IDProjectCategoryView StatusLast Update
0006068ardourbugspublic2016-08-14 13:37
Reporteryouki Assigned To 
Status confirmedResolutionopen 
Summary0006068: Impossible to use properly U-he LXVST plugins
Ardour 3.5.403, tested on Debian Jessie + KXStudio repos and KXStudio 14.04.

The uploaded file shows the normal behaviour of the U-he Satin LXVST plug when clicking right on a knob. In this case used with Carla-git host. The normal behaviour works also with Bitwig-studio. A menu is then opened.

When used with Ardour3 these menus don't open, it affects many features of the plugin. And it also makes the registration of the serial number imossible.

Same problem with U-he Presswerk LXVST plugin.
TagsNo tags attached.


2014-12-10 11:31


Satin (GUI)_001.jpg (241,098 bytes)   
Satin (GUI)_001.jpg (241,098 bytes)   


2014-12-23 01:52

reporter   ~0016072

Problem fixed with the nightly build Ardour-3.5.4049

2016-08-09 18:00

reporter   ~0018350

Issue confirmed, and does not seem to be fixed in Ardour5.0 rc1.4.4. The issue seems to exist at least in the Zebra2 plugin by U-he, In about 5% of the cases the context menu does show up, but disappears before you can click anything. In the splash screen upon loading the instrument you also can not click the "Enter Serial Code" button, which prevents registering and disabling the demo-mode. It is however possible to click the "Purchase license"-button directly above it, and which seems to be the same kind of button.

This leads me to suspect the mechanism that should show any GUI-elements on a higher layer. Likely related to bug 0004732 as this behaviour also persists.

It should be noted that the plugin works fine in BitWig, so that does not seem to be the culprit.

2016-08-09 18:01

reporter   ~0018351

Behaviour is fairly reproduceable


2016-08-13 19:57

administrator   ~0018359

we know now that the linux ports of the U-he plugins use a frankly insane design to create popup menus, dropdowns and file browsers.

these aspects of the GUIs use GTK+3, which cannot exist in the same process as GTK+2 (which Ardour uses), just as is true for Qt3 and Qt4. It is inappropriate for plugins to use a GUI toolkit that may potentially clash with the host's own. They work in Bitwig because Bitwig uses Java for its GUI (so there's no clash).

so the current U-he plugins actually fork a new program when they need to show these GUI elements, which is both crazy and not guaranteed to work.


2016-08-13 19:58

administrator   ~0018360

it would be good to know if the windows are definitely 100% absolutely not on screen, or if they are hidden.

2016-08-14 10:44

reporter   ~0018364

Paul, I tried to test this, but it is kind of hard to draw any conclusions. I can offer you my observations:
- After clicking the "enter serial code" button I tried alt-tab to find a potentially hidden window, but nothing new was shown there.
- I tried looking for processes using pgrep, and could not find any process called VST or Zebra, Zebra2 or any logical permutation that I could think of, so I guess they are child processes of Ardour
- I fired up htop and isolated the Ardour-branch of processes. Indeed, when adding Zebra2 to a strip a couple of new processes spawn.
- Clicking the "enter serial code" button did not spawn any new processes (at least not in the ardour tree)
- after exiting the startup splash screen no processes disappeared, right clicking in the bar that displays the preset name does not spawn processes (but it should display a context menu)
- even if by freak accident I get to see a context menu (happens about 2-5% of the clicks, can not determine what causes these tries to be succesful), the context menu disappears as soon as the mouse gets over it. During the time when it is open it steals some keyboard focus, so I can not alt-tab to search for hidden windows. In these instances I also do not see a change in process count in htop.

The last bullet leaves me thinking that perhaps my method of searching for hidden windows or processes is not the correct approach (as no pid's are added when the menu DOES show). Do you have any suggestions that might give you an answer?


2016-08-14 13:32


Satin_registration.jpg (1,004,177 bytes)


2016-08-14 13:37

reporter   ~0018366

I'm not sure it's related to Ardour. I just tried with Ardour5.0.23, as shown in the file i just uploaded (Satin_registration.jpg) the window to register is showing and usable. No problems with right click menus also.

Issue History

Date Modified Username Field Change
2014-12-10 11:31 youki New Issue
2014-12-10 11:31 youki File Added: Satin (GUI)_001.jpg
2014-12-23 01:52 youki Note Added: 0016072
2016-08-09 18:00 Note Added: 0018350
2016-08-09 18:01 Note Added: 0018351
2016-08-09 18:01 Status new => confirmed
2016-08-13 19:57 paul Note Added: 0018359
2016-08-13 19:58 paul Note Added: 0018360
2016-08-14 10:44 Note Added: 0018364
2016-08-14 13:32 youki File Added: Satin_registration.jpg
2016-08-14 13:37 youki Note Added: 0018366