View Issue Details

IDCategoryLast Update
0005781bugs2020-04-19 20:16
Reporterherr_doktorAssigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version3.0 
Fixed in Version 
Summary0005781: error in latency compensation
DescriptionPlay, then stop, then click backward in the time line, then play: no latency compensation error.
Play, then click backward in the time line without clicking stop before so that play is still engaged: latency compensation error.
Additional InformationArdour 3.4 without VST support, as found in AV Linux. 6 instances of calf fluidsynth, 3 guitar wave tracks, each with amp emulation and IR, one bass wave track with calf comp, IR and 10 band eq. The compensation error is about 50ms (detail: one of the impulses is 0,054 second long, so, it seems to me that not all the instances of Tom Szilgyi's IR are taken into account. Maybe so, maybe not...).
TagsNo tags attached.

Relationships

related to 0006461 feedback XT-VC latency 

Activities

BenLoftis

2015-09-11 20:00

developer   ~0017184

To recreate:

Add 2 tracks, each with the same playlist.
Invert one track so you hear silence.
Add a plugin that adds latency, AND correctly reports it ( I use Harrison XT-LC Lookahead compressor )

Start playback; then click on the timeline to locate back
OR
Initiate loop playback.

In either case, the first play-through will be correctly latency-compensated. But after the locate, you will hear doubling.

x42

2015-09-13 12:52

administrator   ~0017187

yes, known issue. still in current 4.2

A track's playback offset is only [re]-calculated at "stop". Loop playback fails for the same reason.

The idea behind re-calculate latency at "play/stop" was that "plugins do not change their latency while playing". Ardour sets up a fixed offset for disk-read/playback buffer. This is not correct when seeking or looping.

A simple plugin to test with phase-invert is: https://github.com/x42/nodelay.lv2

x42

2015-10-01 21:24

administrator   ~0017408

fixed in Ardour 4.2-478-g4a31b03, please test

herr_doktor

2016-02-07 19:43

reporter   ~0017890

Ok for me, it fits. Sorry for being so long to confirm the fix...

paul

2016-03-08 13:53

administrator   ~0018047

see notes.

system

2020-04-19 20:16

developer   ~0023293

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2013-12-02 13:07 herr_doktor New Issue
2015-09-11 20:00 BenLoftis Note Added: 0017184
2015-09-11 20:01 BenLoftis Priority normal => high
2015-09-11 20:01 BenLoftis Severity minor => major
2015-09-13 12:52 x42 Note Added: 0017187
2015-09-27 21:26 x42 Relationship added related to 0006461
2015-10-01 21:24 x42 Note Added: 0017408
2015-10-01 21:24 x42 Status new => feedback
2016-02-07 19:43 herr_doktor Note Added: 0017890
2016-02-07 19:43 herr_doktor Status feedback => new
2016-03-08 13:53 paul Note Added: 0018047
2016-03-08 13:53 paul Status new => resolved
2016-03-08 13:53 paul Resolution open => fixed
2016-03-08 13:53 paul Assigned To => paul
2020-04-19 20:16 system Note Added: 0023293
2020-04-19 20:16 system Status resolved => closed