View Issue Details

IDCategoryLast Update
0005483bugs2020-04-19 20:16
Reporterraymond83Assigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version3.0 
Fixed in Version 
Summary0005483: Ardour Not Recognising Addictive Drums
DescriptionI have Ardour version 3.0beta4a for MAC OSX 10.6.8.

When Ardour starts up I notice it recognises Addictive Drums as an AU. But it does not show up in the instrument menu once I add a MIDI track.

Paul from the Ardour forum asked me to post this problem here and record the console data, which I have included in the additional info part.
Additional Information13/05/2013 12:02:12 KiesViaWiFiAgent[137] CPU Usage = 0.0
13/05/2013 12:02:12 Ardour3.bin[15796] *** __NSAutoreleaseNoPool(): Object 0x16d0fc00 of class NSCFArray autoreleased with no pool in place - just leaking
13/05/2013 12:02:12 Ardour3.bin[15796] *** __NSAutoreleaseNoPool(): Object 0x17a09ed0 of class NSCFArray autoreleased with no pool in place - just leaking
13/05/2013 12:02:12 Ardour3.bin[15796] *** __NSAutoreleaseNoPool(): Object 0x16d187d0 of class NSCFString autoreleased with no pool in place - just leaking
13/05/2013 12:02:12 Ardour3.bin[15796] *** __NSAutoreleaseNoPool(): Object 0x16d18d60 of class NSCFData autoreleased with no pool in place - just leaking
13/05/2013 12:02:12 Ardour3.bin[15796] *** __NSAutoreleaseNoPool(): Object 0x16d18c90 of class NSCFData autoreleased with no pool in place - just leaking
13/05/2013 12:02:12 Ardour3.bin[15796] *** __NSAutoreleaseNoPool(): Object 0x16d18cc0 of class NSCFData autoreleased with no pool in place - just leaking
13/05/2013 12:02:12 [0x0-0x85085].org.ardour.Ardour3[15796] LANGUAGE set to en
13/05/2013 12:02:12 [0x0-0x85085].org.ardour.Ardour3[15796] LANG set to en_GB
13/05/2013 12:02:12 [0x0-0x85085].org.ardour.Ardour3[15796] Ardour3.0beta4a (built using ['13072'] and GCC version 4.0.1 (Apple Computer, Inc. build 5367))
13/05/2013 12:02:14 [0x0-0x85085].org.ardour.Ardour3[15796] ardour: [INFO]: Loading default ui configuration file /Volumes/Ardour-3.0/Ardour.app/Contents/Resources/ardour3_ui_default.conf
13/05/2013 12:02:14 [0x0-0x85085].org.ardour.Ardour3[15796] Loading user ui configuration file /Volumes/Ardour-3.0/Ardour.app/Contents/Resources/ardour3_ui.conf
13/05/2013 12:02:15 [0x0-0x85085].org.ardour.Ardour3[15796] ardour: [INFO]: Loading ui configuration file /Volumes/Ardour-3.0/Ardour.app/Contents/Resources/ardour3_ui_dark.rc
13/05/2013 12:02:15 [0x0-0x85085].org.ardour.Ardour3[15796] ardour: [INFO]: Removed open file count limit. Excellent!
13/05/2013 12:02:15 KiesViaWiFiAgent[137] CPU Usage = 0.0
13/05/2013 12:02:15 [0x0-0x85085].org.ardour.Ardour3[15796] ardour: [INFO]: Loading user configuration file /Users/Raymond/Library/Preferences/Ardour3/ardour.rc
13/05/2013 12:02:15 [0x0-0x85085].org.ardour.Ardour3[15796] Apple VecLib H/W specific optimizations in use
13/05/2013 12:02:18 KiesViaWiFiAgent[137] CPU Usage = 0.0
13/05/2013 12:02:21 KiesViaWiFiAgent[137] CPU Usage = 0.0
13/05/2013 12:02:24 KiesViaWiFiAgent[137] CPU Usage = 0.1
13/05/2013 12:02:27 KiesViaWiFiAgent[137] CPU Usage = 0.0
13/05/2013 12:02:30 KiesViaWiFiAgent[137] CPU Usage = 0.0
13/05/2013 12:02:30 [0x0-0x85085].org.ardour.Ardour3[15796] Found 5 along /Users/Raymond/Library/Preferences/Ardour3/templates:/Volumes/Ardour-3.0/Ardour.app/Contents/Resources/templates
13/05/2013 12:02:33 KiesViaWiFiAgent[137] CPU Usage = 0.0
13/05/2013 12:02:36 KiesViaWiFiAgent[137] CPU Usage = 0.0
13/05/2013 12:02:37 [0x0-0x85085].org.ardour.Ardour3[15796] (Ardour3.bin:15796): Gtk-WARNING **: Attempting to store changes into `/Users/Raymond/.local/share/recently-used.xbel', but failed: Failed to create file '/Users/Raymond/.local/share/recently-used.xbel.JCLHXW': No such file or directory
13/05/2013 12:02:37 [0x0-0x85085].org.ardour.Ardour3[15796] (Ardour3.bin:15796): Gtk-WARNING **: Attempting to set the permissions of `/Users/Raymond/.local/share/recently-used.xbel', but failed: No such file or directory
13/05/2013 12:02:39 KiesViaWiFiAgent[137] CPU Usage = 0.7
13/05/2013 12:02:42 KiesViaWiFiAgent[137] CPU Usage = 0.0
13/05/2013 12:02:45 KiesViaWiFiAgent[137] CPU Usage = 0.0
13/05/2013 12:02:48 KiesViaWiFiAgent[137] CPU Usage = 0.0
13/05/2013 12:02:51 KiesViaWiFiAgent[137] CPU Usage = 0.1
13/05/2013 12:02:54 KiesViaWiFiAgent[137] CPU Usage = 0.0
13/05/2013 12:02:57 KiesViaWiFiAgent[137] CPU Usage = 0.0
13/05/2013 12:03:00 KiesViaWiFiAgent[137] CPU Usage = 0.0
13/05/2013 12:03:03 KiesViaWiFiAgent[137] CPU Usage = 0.0
13/05/2013 12:03:06 KiesViaWiFiAgent[137] CPU Usage = 0.0
13/05/2013 12:03:08 [0x0-0x85085].org.ardour.Ardour3[15796] Adding MIDI track with in = AUDIO=0:MIDI=1 out = AUDIO=0:MIDI=1
13/05/2013 12:03:09 KiesViaWiFiAgent[137] CPU Usage = 0.0
TagsNo tags attached.

Relationships

duplicate of 0005478 closed AU instantiation of Addictive Drums fails 

Activities

paul

2013-06-13 13:06

administrator   ~0014987

addictive drums has an EXTREMELY unconventional and unhelpful way of reporting its I/O configuration. it does not support the typical technique that every other plugin i've tested uses, but instead declares that it has 12 output "elements", whose output configuration varies between stereo and mono.

this is done, rather than just reporting that it has 16 channels, as the case with other typical multichannel, multipart plugins. the result is complexity for the user (which channel is which, which are grouped in stereo pairs, how to route within a given DAW), and complexity for the host developer, who has to handle this multi-element design even though it doesn't actually bring anything useful to the user.

i will do some work on supporting this in the future, but i am not sure when. it could be very soon, or i may decide that its just so stupid that it should be deferred.

paul

2016-08-24 16:12

administrator   ~0018473

Ardour 5.0 works without issues with AD. It was one of the specific plugins we used for testing.

paul

2016-08-24 16:12

administrator   ~0018474

works fine in ardour 5.0

system

2020-04-19 20:16

developer   ~0023230

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2013-05-13 11:04 raymond83 New Issue
2013-06-13 13:03 paul Relationship added duplicate of 0005478
2013-06-13 13:06 paul Note Added: 0014987
2016-08-24 16:12 paul Note Added: 0018473
2016-08-24 16:12 paul Note Added: 0018474
2016-08-24 16:12 paul Status new => resolved
2016-08-24 16:12 paul Resolution open => fixed
2016-08-24 16:12 paul Assigned To => paul
2020-04-19 20:16 system Note Added: 0023230
2020-04-19 20:16 system Status resolved => closed