View Issue Details

IDCategoryLast Update
0005007features2017-07-19 14:12
ReportercolinfAssigned Topaul 
ReproducibilityN/A 
Status newResolutionno change required 
Product Version 
Fixed in Version 
Summary0005007: Make scroll wheel without modifiers in session overview pane scroll sideways
DescriptionI've realised as I work more with A3 now that one of the things I'd use often in A2 was scroll-wheel on the bottom scroll bar of the editor window to scroll forwards & back in the session, and I'm missing the ability to do the same in A3.

I know <Alt>+scroll-wheel does the same thing in A3, but that's not so ergonomic for me: I usually use the mouse left-handed, and I have a UK keyboard where there's only one <Alt> key, on the left (the one on the right is <Alt Gr>).

Given that it's possible to scroll the main editor pane up & down directly with the scroll wheel without modifiers, I think that making the unmodified action in the overview pane be sideways scroll is an (admittedly slight) usability improvement, at the (slight) cost of some consistency.

Thoughts, anyone?
TagsNo tags attached.

Activities

paul

2012-07-12 13:25

administrator   ~0013871

this seems wrong to me given that most (many?) mice with scroll wheels these days have left/right scrolling too.

colinf

2012-07-12 13:42

updater   ~0013872

Yeah, fair enough. Time for me to buy a new mouse, then?

paul

2012-07-14 21:35

administrator   ~0013892

for now, i'm marking this as no change required. i think the lack of consistency is much worse than either having to use alt-scroll or use a mouse with L/R scrolling.

colinf

2017-07-19 14:12

updater   ~0019901

Given that since ea052417 scrolling behaviour between the editor and the summary isn't the same any more, I'd argue that making scroll up/down over the summary move along the timeline could be a more useful behaviour than zooming.

Issue History

Date Modified Username Field Change
2012-07-12 13:03 colinf New Issue
2012-07-12 13:25 paul Note Added: 0013871
2012-07-12 13:42 colinf Note Added: 0013872
2012-07-14 18:28 cth103 cost => 0.00
2012-07-14 18:28 cth103 Target Version => 3.0
2012-07-14 21:35 paul Note Added: 0013892
2012-07-14 21:35 paul Status new => resolved
2012-07-14 21:35 paul Resolution open => no change required
2012-07-14 21:35 paul Assigned To => paul
2017-07-19 14:12 colinf Note Added: 0019901
2017-07-19 14:12 colinf Status resolved => new