View Issue Details

IDCategoryLast Update
0000050bugs2008-11-20 23:58
ReporteressejAssigned Totaybin 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000050: audio_clock widgets have mouse event problems
DescriptionThe audio_clock doesn't appear to respond as designed to click and drag actions. The shift-mousewheel is ok, as is the numeric keyboard entry, but everything else is screwy.
TagsNo tags attached.

Activities

taybin

2004-05-17 02:49

administrator   ~0000766

Was this fixed?

vandongen

2004-12-08 21:06

updater   ~0001683

no, there is no click-drag adjustment that I can see.
Should there be?
With keyboard editing there is a really minor item, the keyboard editing of the time clocks removes a leading zero in the minutes field after enter/deselecting.
Even though it adds it as you are editing the seconds.

vandongen

2005-01-26 10:17

updater   ~0001930

click drag adjustment only increases the clocks, it is impossible to decrease the clock.
It is also very unresponsive and jumpy.

With my keyboard-mousewheel emulation it is also acting weird, jumping from field to field. Possibly because I am generating clicks and not mouse-down and mouse-up events

Shift middle click sets to zero, which makes sense for the mouse-wheel, but is different from the faders where shift-button1 resets.
Maybe both should reset for clocks and for faders.
In general the bindings for clocks and faders should be identical

vandongen

2005-02-04 08:44

updater   ~0001963

I believe I fixed this in CVS ( 0.569.0 with libardour 0.865.0)

Issue History

Date Modified Username Field Change
2003-10-16 14:43 essej New Issue
2004-05-17 02:49 taybin Note Added: 0000766
2004-12-08 21:06 vandongen Note Added: 0001683
2005-01-26 10:17 vandongen Note Added: 0001930
2005-02-04 08:44 vandongen Note Added: 0001963
2007-02-14 22:36 taybin Status new => resolved
2007-02-14 22:36 taybin Resolution open => fixed
2007-02-14 22:36 taybin Assigned To => taybin
2008-11-20 23:58 seablade Status resolved => closed