View Issue Details

IDCategoryLast Update
0000472features2015-11-17 02:57
ReporterruchirAssigned Topaul 
ReproducibilityN/A 
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000472: Copy/duplicate track
DescriptionA feature to copy a track and all its settings to a new track. This will speed up duplicating tracks with surround panning layouts and insert/send settings for example.
TagsNo tags attached.

Activities

oofus

2010-07-22 14:36

developer   ~0008584

Is this covered by templates, and if so does that resolve this issue ?

in0giro

2012-01-19 14:35

reporter   ~0012579

+1

naught101

2014-01-05 05:41

reporter   ~0015545

oofus: you mean save a single track as a template, then import it or something? I'm not even sure if that works, but it would be a lot of work to go to, if you're halfway through a song, and just want to duplicate one of 5 tracks (delete all the other tracks, save as a template, quit without saving, re-open, import template??).

There is a good use-case here: http://youtu.be/HOWTTEHw4k8?t=13m26s - basically, you have a complex synth plugin configured with lots of settings, then you want a simple variation of it (a few parameters differnt), without having to screw around with automation.

x42

2014-01-05 13:00

administrator   ~0015546

I think "duplicating a track" for "screwing around with plugin setting" is the wrong approach.

The reason for this:
 * You *do* want to "screw around with parameters"
 * You *do not* actually want to duplicate the track.
It's just a 'creative workaround', not a solution.

For Audio-tracks there are already various proper solutions (A/B plugins, or use Busses, Aux-send to effect-busses,..), which of those is right depends on the context. Midi-tracks are still behind (only one synth, no A/B possible)


PS. You can also already 'duplicate' audio tracks without the associated automation data, by simply creating new track and choosing the playlist ('p' button of the track-header) of some other track. For Midi-tracks this is yet another feature on the ToDo list.

PPS. You could edit the raw ardour.session XML and duplicate the track by copy/paste (just change the unique IDs).

paul

2015-11-17 02:56

administrator   ~0017614

now present in git master.

paul

2015-11-17 02:57

administrator   ~0017615

sometimes it takes 9 years ....

Issue History

Date Modified Username Field Change
2004-05-22 12:12 ruchir New Issue
2004-05-22 12:12 ruchir Name => Ruchir
2004-05-24 14:07 taybin Priority urgent => low
2010-07-22 14:36 oofus Note Added: 0008584
2010-07-22 14:36 oofus cost => 0.00
2010-07-22 14:36 oofus Target Version => 3.X
2012-01-19 14:35 in0giro Note Added: 0012579
2014-01-05 05:41 naught101 Note Added: 0015545
2014-01-05 13:00 x42 Note Added: 0015546
2015-11-17 02:56 paul Note Added: 0017614
2015-11-17 02:57 paul Note Added: 0017615
2015-11-17 02:57 paul Status new => resolved
2015-11-17 02:57 paul Resolution open => fixed
2015-11-17 02:57 paul Assigned To => paul