View Issue Details

IDProjectCategoryView StatusLast Update
0004596ardourpublic2012-04-23 10:48
ReporterLeonardo Assigned Topaul  
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version3.0-alpha10 
Summary0004596: press spacebar for start and Ardour block himself
Descriptionsorry i'm italian so i can't write english very well!

However, everytime (on the 1┬░alpha release of Ardour3.0 and on last alpha10 release of Ardour3.0) i press on the spacebar for play, ardour block himself and the mouse can't click anything! i have to restart the computer using my keyboard!

i use Ubuntu 11.04 desktop version 32 bit, is better if i use ubuntu 11.10?


Thank you, i really love last release of Ardour (GTK2) so i hope to use this last release!
Additional InformationContact me for answers!

(i use jack before starting Ardour)
TagsNo tags attached.

Activities

Leonardo

2011-12-28 14:06

reporter   ~0012483

When i open ardour this appear to me:

[INFO]: looking for control protocols in /opt/Ardour-3.0alpha10_10000-dbg/lib/surfaces
[INFO]: Control surface protocol discovered: "Generic MIDI"
[INFO]: Control surface protocol discovered: "Mackie"
[INFO]: Control surface protocol discovered: "Open Sound Control (OSC)"
[INFO]: Loading menus from /opt/Ardour-3.0alpha10_10000-dbg/etc/ardour.menus
[WARNING]: This version of JACK is old - you should upgrade to a newer version that supports jack_port_type_get_buffer_size()
[ERROR]: JACK: Cannot use real-time scheduling (RR/5)(1: Operazione non permessa)
[ERROR]: JACK: AcquireRealTime error
[ERROR]: JACK: Cannot create thread res = 1
[ERROR]: JACK: Cannot create thread res = 1
[ERROR]: JACK: Cannot create thread res = 1
[INFO]: Loading bindings from /opt/Ardour-3.0alpha10_10000-dbg/etc/mnemonic-us.bindings
Loading history from /media/LACIE 2TB/assq/assq.history

paul

2011-12-30 14:36

administrator   ~0012498

Leonardo, this warning is not to be ignored:

[WARNING]: This version of JACK is old - you should upgrade to a newer version that supports jack_port_type_get_buffer_size()

In addition, your system is apparently not correctly configured for realtime low latency audio (hence the ERROR messages that appear after that one).

http://jackaudio.org/linux_rt_config

Ubuntu 11.04 has caused problems for a lot of people who want to use software like Ardour and JACK. 11.10 is a *bit* better.

Leonardo

2011-12-30 14:52

reporter   ~0012499

Paul, thank you, but with this jack version and last version of Ardour (GTK2) everything works very well (except for some little bugs, which are not always!


i haven't a Kernell RT, because i don't know how to install it :) i'm not an expert user!

when this version of Ardour will be ready, i'll try to use it!

thank you!

paul

2011-12-30 14:57

administrator   ~0012500

ardour3 is a totally different program in many ways than ardour2. when we print warning messages like that, we mean it.

if you read the page i referred you to, you will see that having an RT kernel has absolutely nothing to do with correct realtime scheduling configuration. *nothing*.

paul

2012-04-23 10:48

administrator   ~0013165

as noted, this bug is almost certainly caused by using a too-old version of JACK. if it can be shown to occur with a reasonably current version of JACK, please reopen it.

Issue History

Date Modified Username Field Change
2011-12-28 13:59 Leonardo New Issue
2011-12-28 14:06 Leonardo Note Added: 0012483
2011-12-28 14:06 Leonardo Status new => feedback
2011-12-28 17:34 cth103 cost => 0.00
2011-12-28 17:34 cth103 Target Version => 3.0-beta2
2011-12-30 14:36 paul Note Added: 0012498
2011-12-30 14:52 Leonardo Note Added: 0012499
2011-12-30 14:57 paul Note Added: 0012500
2012-01-10 20:45 cth103 Target Version 3.0-beta2 => 3.0-beta3
2012-02-14 17:20 paul Target Version 3.0-beta3 => 3.0 beta4
2012-04-23 09:34 cth103 Category bugs => support
2012-04-23 09:34 cth103 Target Version 3.0 beta4 =>
2012-04-23 10:48 paul Note Added: 0013165
2012-04-23 10:48 paul Status feedback => resolved
2012-04-23 10:48 paul Resolution open => won't fix
2012-04-23 10:48 paul Assigned To => paul
2012-06-02 16:50 cth103 Category support => (No Category)