View Issue Details

IDCategoryLast Update
0000451bugs2012-06-24 13:37
ReportertitoAssigned Tocth103 
Reproducibilityalways 
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0000451: Varispeed does not respect looping/locate
DescriptionWhen I change playback speed in loop mode (varispeed = wheel) transport stops at the end of the session. Same goes for locate. It would -- at least to me -- feel more natural if wheel/transport would stay where I put it. And it should loop of course. Well, I'm not even sure if this is supposed to be a feature ... enlightenment someone?
Additional Informationcvs tarball 05/15/2004
TagsNo tags attached.

Relationships

related to 0004541 resolvedpaul Wheel mode playback speed ignored after locate 
child of 0001334 new Varispeed design issues 

Activities

atreju

2006-11-19 18:32

updater   ~0002814

Last edited: 2006-11-19 18:53

The behaviour is the same for ardour 2.0 svn rev 1137.

there are various issues here (maybe it should be listed in more than one bug)

- press play, change speed --> transport plays till the end of the session and speed is set back to normal.
- change speed when stopped --> transport starts to roll, but the stop button is still highlighted (instead of the play button)
- press play, change speed, move the transport bar --> transport is relocated but speed is reset to one.

the loop seems to be a bug, the rest looks like some behaviour that needs some talk.

in my opinion, when set to wheel mode, varispeed should retain the setting.

atreju

2006-11-19 18:57

updater   ~0002815

Various related issues have been reported. bug 1334 is their parent.

they have been split since they don't have the same severity.

cth103

2010-05-01 20:08

administrator   ~0007704

I'm not sure I quite understand what bug this is referring to. Can you clarify? Is it still an issue?

mikkl

2012-06-21 10:31

reporter   ~0013648

I, too, can confirm that this is not the behaviour u would expect.
Yesterday i wanted to show a bandmate something in a loop with the tempo decreased (shuttle speed control in wheel mode). But everytime the loops begins from anew speed control changes back to 100%. Same is with relocating. I don't see a reason why it should jump back. Maybe the current behaviour is thought to be an easy reset to 100% when you relocate. But then at least while looping this behaviour is not wanted.

paul

2012-06-22 14:30

administrator   ~0013659

this is fixed in rev 12818.

Issue History

Date Modified Username Field Change
2004-05-16 01:35 tito New Issue
2004-05-16 01:35 tito E-mail => tito@rumford.de
2006-11-19 18:24 atreju Priority urgent => normal
2006-11-19 18:24 atreju Status new => feedback
2006-11-19 18:32 atreju Note Added: 0002814
2006-11-19 18:35 atreju Note Edited: 0002814
2006-11-19 18:40 atreju Relationship added related to 0001089
2006-11-19 18:52 atreju Relationship added child of 0001334
2006-11-19 18:52 atreju Relationship deleted related to 0001089
2006-11-19 18:53 atreju Note Edited: 0002814
2006-11-19 18:55 atreju Severity tweak => feature
2006-11-19 18:57 atreju Note Added: 0002815
2007-02-15 22:05 taybin Status feedback => acknowledged
2010-05-01 20:08 cth103 Note Added: 0007704
2010-05-01 20:08 cth103 Status acknowledged => feedback
2010-07-22 14:35 oofus cost => 0.00
2010-07-22 14:35 oofus Target Version => 3.X
2012-06-21 10:31 mikkl Note Added: 0013648
2012-06-22 14:30 paul Note Added: 0013659
2012-06-22 14:31 paul Relationship added related to 0004541
2012-06-24 13:37 cth103 Status feedback => resolved
2012-06-24 13:37 cth103 Resolution open => fixed
2012-06-24 13:37 cth103 Assigned To => cth103