View Issue Details

IDProjectCategoryView StatusLast Update
0004172ardourbugspublic2011-11-04 17:13
Reporterin0giro Assigned To 
Status resolvedResolutionopen 
PlatformIntel Core2 DuoOSGentoo amd64 + Pro-Audio overlayOS Versionstable
Target Version3.0-beta1 
Summary0004172: MIDI track/region non-playback
Descriptioni have a session with a few MIDI tracks. let us start with "demonstrate organ 01", playlist "demonstrate organ 01.2", region "demonstrate organ 01-4.1" starting at measure 176 that has the following problems:

1) the region is *usually* played the first time it is encountered

2) upon stopping and restarting playback before the region, subsequent passes *usually* do not play back the region *unless* the play head is dragged back *without* stopping playback. this trick results in playback about 95% of the time. another trick to get playback is to use the left arrow key to move the cursor back to the start, NOT before, of the MIDI region when that region/track is selected. regardless, notes after ~measure 187.5 are always ignored.

3) copy this region to the other MIDI track "nails 01" and the region plays fine a few times, then same deal.

4) also, the "nails 01" MIDI track has its own regions at the same area of the time line and they also experience the same problem.

the other playlists on the "demonstrate organo 01" and "nails 01" tracks have similar problems, but are shorter.

finally, the key seems to be that if the play head is coming from *before* the regions, playback of that region is often skipped. if the play head is started from *within* the region, playback usually works.
Steps To Reproducei have been unable to create a new session from scratch that reproduces the same problems. thus i am attaching the original session where i discovered the problems, as well as the MIDI files, in a compressed bundle. NOTE that i have left out the audio files and tested it locally with them gone: the problems persist.

1) open session "for demonstration purposes [2011.07.01].ardour"
2) choose "Skip all missing files" from the resulting "Missing File!" dialog (i have left the audio files out of the attached bundle, only MIDI files are included)
3) move the play head (if necessary) to measure 175
4) press play
5) first time usually has playback of both MIDI tracks, then if the play head is moved *before* both regions start at measure 176, the problems begin.
Additional Informationsome notes:

1) the session load causes the following console output:

WARNING: Sequence<Time>::end_write: Channel 0 has 4 stuck notes
WARNING: Sequence<Time>::end_write: Channel 0 has 4 stuck notes
WARNING: Sequence<Time>::end_write: Channel 0 has 4 stuck notes
WARNING: Sequence<Time>::end_write: Channel 0 has 4 stuck notes
WARNING: Sequence<Time>::end_write: Channel 0 has 4 stuck notes
WARNING: Sequence<Time>::end_write: Channel 0 has 3 stuck notes

2) it seems to occur with both MIDI tracks, though the "nails 01" MIDI track *seems* to playback correctly more often than the demonstrate organ 01" MIDI track

3) it occurs whether the synths generating the sounds are external or internal.

4) live playing with an external MIDI controller always produces sound

5) all MIDI regions in the session were recorded with Ardour 3 using the same external MIDI controller, and while recording the regions there were no problems

6) when a region is not played back, non MIDI activity is shown in the activity meter of the MIDI track strip in the editor window

7) there is a loud pop/noise that occurs on every start of playback (i have no idea where it is coming from, everything is muted except what is needed for the MIDI playback). KEEP THE SESSION REVERB MUTED to keep from blowing your ears/etc. even with every track muted except the session reverb bus and master, the pop still occurs.

8) some of the tracks (often the MIDI tracks and master) will change their order on every session load.
TagsNo tags attached.


2011-07-12 02:49



2011-07-12 09:52

administrator   ~0011083

Unfortunately this seems to work for me, here. Do you mean measure 176? I don't see any regions there. Also can you clarify what you mean by

6) when a region is not played back, non MIDI activity is shown in the activity meter of the MIDI track strip in the editor window

Do you mean that when the region is not playing back (when it should be) the meters do or do not show activity?

2011-07-12 14:36


AmbientThing5.tar.gz (52,976 bytes)


2011-07-12 14:41

reporter   ~0011097

I've just attached a complete session of my own -- it seems to exhibit the same (or a very similar) problem. If I have grid snapping enabled, move the playhead a few beats or a bar before the start of a bunch of MIDI regions, and then hit play, some or all of the tracks will fail to play nearly every time.

There are two ways I've found to play these tracks more reliably:
* hitting play, and then grabbing the playhead and moving it back while the transport is running -- after that, all my MIDI tracks seem to play
* turning off grid snapping and then positioning the playhead before hitting play; I *think* this has some effect, but it's definitely not as reliable as the above method

You won't have all the synths I've used, but connecting your own, or simply watching the peak meters on the MIDI tracks, should be enough to show the problem.


2011-07-12 15:19

reporter   ~0011099

cth103: on the MIDI tracks "demonstrate organ 01" and "nails 01" there should be MIDI regions starting at measure 176 (i can see them from the same bundle right now), in various play lists of each track. try running the session like this:

ardour3 "Ardour 3/for demonstration purposes [2011.07.01]/for demonstration purposes [2011.07.01].ardour"

when run like this, the MIDI regions should appear. i think this is due to some bug/confusion (maybe related to ) that occurs when i create a new Ardour 3 session in the following folder setup, rooted in the "project" folder:

<project-name>/Ardour 3/<project-name>/project-name.ardour

and i always launch the session file from the "root" folder of the project using relative paths, as i listed above. for some reason, if i go into the Ardour session directory and run "ardour3 "project-name.ardour", Ardour 3 cannot find the media (i.e. audio & MIDI files). note that this never happens with Ardour 2. since it is not a crashing bug, i have not pursued it very much yet.

in answer to your second question: when the region is not played back, but should be, the MIDI track strip shows no activity.

thanks and sorry for the confusion.


2011-07-12 15:45

reporter   ~0011100

cth103: better yet, run the session file with the full path, for example

ardour3 "/home/in0giro/roba/Ardour 3.x/for demonstration purposes [2011.07.01]/Ardour 3/for demonstration purposes [2011.07.01]/for demonstration purposes [2011.07.01].ardour"

or wherever you put the session folder. that should ensure that the MIDI regions appear. if they do not appear, you will see a console message during startup:

Playlist with ID = 64315 not found
Playlist with ID = 53390 not found
Playlist with ID = 129824 not found

again, for some reason running it from with the session folder causes media to not be found.


2011-07-22 17:16

reporter   ~0011188

so far issue seems resolved in 9910.



2011-07-29 18:42

reporter   ~0011235

unfortunately, this bug still exists in rev. 9942, though it occurs much less frequently. the trick listed in #2 above in Description (i.e. dragging the playhead while the transport is running) will cause the region to play.

though i cannot create MIDI regions with missing note offs as we originally were, regions that are recorded fine are just not played sometimes (though MIDI meter shows activity).


2011-10-24 22:18

administrator   ~0011772

Sorry it's been a while. Is the recipe for reproduction of this bug still the same as the one you originally reported? Is the non-playing always accompanied by the MIDI meter showing activity?


2011-10-26 00:17

reporter   ~0011792

I've just tested this here again -- it looks like in my case, when a region that should be playing is not actually playing, there's no activity in the MIDI meter on that track. This occurs on at least two tracks within this project.

Repositioning the playhead while the transport is running always seems to make the MIDI regions play as expected.

So far, I haven't been able to reproduce this problem within any new project -- it's only this one project, which I've been working on for a few months, that seems to be affected.

Let me know if you'd like a copy of the problematic session; the copy that I attached to this ticket no longer opens (which may be a bug in itself).


2011-10-26 01:30

administrator   ~0011797

Thanks for testing again. A new copy of the session would be great. I'll also try to take a look at why the old one doesn't open any more.

2011-10-26 06:16


AmbientThing5-3.tar.gz (95,196 bytes)


2011-10-26 06:21

reporter   ~0011801

I've just attached a newer copy of the session (AmbientThing5-3.tar.gz) -- it loads in to current Ardour 3 SVN, and it exhibits the problem for me. Perhaps the easiest track to see the problem on is the track called "doot" -- it has a Calf Monosynth plugin on it, so if you have that plugin installed (I'm using Calf from git, but I think an officially released version should suffice), you'll both see and hear the problem.

The most reliable way to see the problem is to play the session from the very beginning; the track will fail to play once every three or four times on average. No activity occurs on the track's MIDI meter, and no audio is heard.

When you manage to reproduce that, try repositioning the playhead while the transport is running -- the notes should immediately start to sound.

I'm sorry that I don't have a simpler test session, but so far I've been unable to reproduce this in any other session.


2011-10-31 21:17

administrator   ~0011838

Last edited: 2011-11-01 01:34

SVN 10362 fixes it for me, perhaps you could test?

p.s. excellent test case by the way, thanks.


2011-11-01 00:16

reporter   ~0011845

That seems to have fixed it for me, too -- I've played through the track from the start several times now, and all the MIDI regions have played just as expected. Nice work!


2011-11-02 01:49

reporter   ~0011872

with SVN rev. 10379 on the session that most often displayed this problem, so far after a bunch of playbacks, the MIDI is not skipping. thanks so much!

Issue History

Date Modified Username Field Change
2011-07-12 02:49 in0giro New Issue
2011-07-12 02:49 in0giro File Added: for demonstration purposes [2011.07.01].tar.bz2
2011-07-12 09:18 cth103 cost => 0.00
2011-07-12 09:18 cth103 Target Version => 3.0-beta1
2011-07-12 09:52 cth103 Note Added: 0011083
2011-07-12 09:52 cth103 Status new => feedback
2011-07-12 14:36 pneuman File Added: AmbientThing5.tar.gz
2011-07-12 14:41 pneuman Note Added: 0011097
2011-07-12 15:19 in0giro Note Added: 0011099
2011-07-12 15:45 in0giro Note Added: 0011100
2011-07-22 17:17 in0giro Note Added: 0011188
2011-07-29 18:42 in0giro Note Added: 0011235
2011-10-24 22:18 cth103 Note Added: 0011772
2011-10-26 00:17 pneuman Note Added: 0011792
2011-10-26 01:30 cth103 Note Added: 0011797
2011-10-26 06:16 pneuman File Added: AmbientThing5-3.tar.gz
2011-10-26 06:21 pneuman Note Added: 0011801
2011-10-29 21:33 cth103 Status feedback => confirmed
2011-10-31 21:17 cth103 Note Added: 0011838
2011-11-01 00:16 pneuman Note Added: 0011845
2011-11-01 01:34 cth103 Note Edited: 0011838
2011-11-02 01:49 in0giro Note Added: 0011872
2011-11-04 17:13 cth103 Status confirmed => resolved