View Issue Details

IDCategoryLast Update
0003835bugs2014-12-31 04:45
ReporterdanboidAssigned Todrobilla 
Reproducibilityalways 
Status closedResolutionno change required 
Product Version 
Fixed in Version 
Summary0003835: configure checks for gtk+-2.0 and slv2 twice
DescriptionThe 4 duplicate lines in configure as it stands are:

Checking for slv2 >= 0.6.4 : yes
Checking for slv2 >= 0.7.0 : yes

Checking for gtk+-2.0 >= 2.12.1 : yes
Checking for gtk+-2.0 >= 2.18 : yes

So which versions does it really require? The latest I'd presume.
TagsNo tags attached.

Activities

cth103

2011-03-07 14:08

administrator   ~0010307

The slv2 checks are duplicated because it needs to know which version you have to adapt accordingly. The gtk one I guess is probably slightly superfluous.

drobilla

2014-12-31 04:44

developer   ~0016184

This is deliberate. Ardour is checking for various versions to see what it can use from the libraries with conditional compilation.

Issue History

Date Modified Username Field Change
2011-03-07 08:20 danboid New Issue
2011-03-07 14:08 cth103 Note Added: 0010307
2011-03-07 14:08 cth103 cost => 0.00
2011-03-07 14:08 cth103 Target Version => 3.X
2014-12-31 04:44 drobilla Note Added: 0016184
2014-12-31 04:45 drobilla Assigned To => drobilla
2014-12-31 04:45 drobilla Status new => closed
2014-12-31 04:45 drobilla Resolution open => no change required