View Issue Details

IDCategoryLast Update
0003134bugs2021-05-08 15:15
ReporterdanboidAssigned Tocth103 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version 
Fixed in Version 
Summary0003134: MIDI controllers menu disappears
Description* Create a MIDI track

* Click on Automation icon- note that first time you do this you can access items in 'Controllers' menu

* Click off menu

* Click automation icon again - Controllers menu label is still visible but sub-menus are gone.

Present in r7101
TagsNo tags attached.

Relationships

related to 0008695 resolvedpaul Ardour crashes when drawing automations (right-click only) 

Activities

2010-05-16 15:31

 

test.cc.txt (922 bytes)
#include <iostream>
#include <gtkmm/main.h>
#include <gtkmm/button.h>
#include <gtkmm/window.h>
#include <gtkmm/menu.h>

using namespace std;
using namespace Gtk;
using namespace Gtk::Menu_Helpers;

Menu* sub_menu = 0;
Menu* menu = 0;

void make_submenu ()
{
        sub_menu = new Menu;
        sub_menu->items().push_back (MenuElem ("Fred"));
}

void make_menu ()
{
        delete menu;
        menu = new Menu;
        menu->items().push_back (MenuElem ("Jim", *sub_menu));
}

void foo ()
{
        make_menu ();
        menu->popup (1, gtk_get_current_event_time ());
}

int main (int argc, char* argv[])
{
        Main kit (argc, argv);

        Window w;

        make_submenu ();

        Button* b = new Button ("Foo");
        b->signal_clicked().connect (sigc::ptr_fun (foo));

        w.add (*b);
        w.show_all ();

        Main::run (w);
        return 0;
}
test.cc.txt (922 bytes)

cth103

2010-05-16 15:31

administrator   ~0007909

Looks a little like a GTK bug, to me. The attached test-case exhibits the same problem.

cth103

2010-05-16 18:03

administrator   ~0007911

Fixed / worked-around in SVN. Thanks for the report!

system

2020-04-19 20:14

developer   ~0022060

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2010-05-14 11:14 danboid New Issue
2010-05-16 00:01 cth103 Status new => confirmed
2010-05-16 00:01 cth103 cost => 0.00
2010-05-16 00:01 cth103 Target Version => 3.0-beta1
2010-05-16 15:31 cth103 File Added: test.cc.txt
2010-05-16 15:31 cth103 Note Added: 0007909
2010-05-16 18:03 cth103 Note Added: 0007911
2010-05-16 18:03 cth103 Status confirmed => resolved
2010-05-16 18:03 cth103 Resolution open => fixed
2010-05-16 18:03 cth103 Assigned To => cth103
2020-04-19 20:14 system Note Added: 0022060
2020-04-19 20:14 system Status resolved => closed
2021-05-08 15:15 x42 Relationship added related to 0008695