View Issue Details

IDCategoryLast Update
0002492bugs2020-04-19 20:13
ReporterDaniel_JAssigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version2.7.1 
Fixed in Version 
Summary0002492: Ardour 2.7.1 fails to compile with GCC 4.4 - patch attached
DescriptionGCC 4.4 (not released yet, but available via SVN builds) is more strict about explicit inclusion of headers. The attached patch explicitly includes the headers that had previously been implicitly included.
Additional InformationThis patch has also been submitted to the Gentoo bugzilla.
http://bugs.gentoo.org/show_bug.cgi?id=251034
TagsNo tags attached.

Activities

2008-12-15 16:39

 

ardour-2.7.1-gcc44.patch (1,418 bytes)
diff -Naur ardour-2.7.1.orig/libs/pbd/convert.cc ardour-2.7.1/libs/pbd/convert.cc
--- ardour-2.7.1.orig/libs/pbd/convert.cc	2008-12-09 15:34:12.544005281 -0500
+++ ardour-2.7.1/libs/pbd/convert.cc	2008-12-09 15:34:47.962006119 -0500
@@ -17,6 +17,7 @@
 
 */
 
+#include <cstdio>
 #include <cmath>
 #include <locale>
 #include <algorithm>
diff -Naur ardour-2.7.1.orig/libs/pbd/pbd/convert.h ardour-2.7.1/libs/pbd/pbd/convert.h
--- ardour-2.7.1.orig/libs/pbd/pbd/convert.h	2008-12-09 15:34:12.546005001 -0500
+++ ardour-2.7.1/libs/pbd/pbd/convert.h	2008-12-09 16:01:25.177005281 -0500
@@ -20,6 +20,7 @@
 #ifndef __pbd_convert_h__
 #define __pbd_convert_h__
 
+#include <stdint.h>
 #include <string>
 #include <vector>
 #include <sstream>
diff -Naur ardour-2.7.1.orig/libs/pbd/shortpath.cc ardour-2.7.1/libs/pbd/shortpath.cc
--- ardour-2.7.1.orig/libs/pbd/shortpath.cc	2008-12-09 15:34:12.550005001 -0500
+++ ardour-2.7.1/libs/pbd/shortpath.cc	2008-12-09 15:44:23.709005001 -0500
@@ -17,6 +17,7 @@
 
 */
 
+#include <stdint.h>
 #include <pbd/shortpath.h>
 
 using namespace Glib;
diff -Naur ardour-2.7.1.orig/libs/pbd/stacktrace.cc ardour-2.7.1/libs/pbd/stacktrace.cc
--- ardour-2.7.1.orig/libs/pbd/stacktrace.cc	2008-12-09 15:34:12.550005001 -0500
+++ ardour-2.7.1/libs/pbd/stacktrace.cc	2008-12-09 15:46:27.671005281 -0500
@@ -17,6 +17,7 @@
 
 */
 
+#include <cstdio>
 #include <pbd/stacktrace.h>
 #include <iostream>
 
ardour-2.7.1-gcc44.patch (1,418 bytes)

seablade

2009-01-28 02:16

manager   ~0005655

Assigning to Paul to take a look at the patch. Thanks.

     Seablade

Daniel_J

2009-02-12 15:24

reporter   ~0005699

This patch includes <stdint.h>, but it might be better to include <cstdint> instead.

Daniel_J

2009-02-17 17:23

reporter   ~0005722

Hmm. Probably better to stick with <stdint.h>. If you include <cstdint>, you also have to set -std=c++0x in the CFLAGS (at least for GCC 4.4).

paul

2009-03-02 20:06

administrator   ~0005782

patch applied to 2.0-ongoing, rev 4719

system

2020-04-19 20:13

developer   ~0021840

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2008-12-15 16:39 Daniel_J New Issue
2008-12-15 16:39 Daniel_J File Added: ardour-2.7.1-gcc44.patch
2009-01-28 02:16 seablade Status new => assigned
2009-01-28 02:16 seablade Assigned To => paul
2009-01-28 02:16 seablade Note Added: 0005655
2009-02-12 15:24 Daniel_J Note Added: 0005699
2009-02-17 17:23 Daniel_J Note Added: 0005722
2009-03-02 20:06 paul cost => 0.00
2009-03-02 20:06 paul Status assigned => resolved
2009-03-02 20:06 paul Resolution open => fixed
2009-03-02 20:06 paul Note Added: 0005782
2010-04-24 10:28 cth103 Category bugs => bugs2
2010-04-24 10:31 cth103 Category bugs2 => bugs
2020-04-19 20:13 system Note Added: 0021840
2020-04-19 20:13 system Status resolved => closed