View Issue Details

IDCategoryLast Update
0002139bugs2019-05-30 11:10
ReporterpuddingpimpAssigned Tocth103 
Reproducibilityalways 
Status feedbackResolutionreopened 
Product Version 
Fixed in Version 
Summary0002139: MIDI notes sustain when playhead is stopped.
DescriptionNo MIDI-off events are emitted when the playhead is stopped while one or more notes are being played.
Additional InformationSteps to reproduce:
1. Load some midi data.
2. Connect midi track to synth/midi monitor/etc.
3. press play.
4. stop playhead during note.
TagsNo tags attached.

Relationships

has duplicate 0006882 feedback Midi note continue playing 

Activities

danboid

2010-07-26 11:55

reporter   ~0008653

No longer a problem in my experience

'pimp?

cth103

2010-08-14 00:03

administrator   ~0008831

Closing this due to lack of feedback. Please re-open if it is still a problem. Thanks!

robertnyles

2014-11-14 20:11

reporter   ~0015975

It's still a problem. Not only that ardour doesn't send a MIDI-off. When I have the sustain pedal on before playhead and I start playing the coming notes should be sustained but they aren't.

Some-E

2016-06-12 08:25

reporter   ~0018252

It's still a problem, confirmed in 4.6 and 4.7.

robertnyles

2016-10-19 10:51

reporter   ~0018845

It's still a problem in 5.4.

cooltehno_bugs

2016-10-31 14:58

reporter   ~0018892

Have the same problem in 4.7, 5.3. It has a place, when transport-loop-playing is going (if the midi note is continuing at the end of loop)

Issue History

Date Modified Username Field Change
2008-03-25 04:13 puddingpimp New Issue
2010-07-21 15:43 cth103 cost => 0.00
2010-07-21 15:43 cth103 Target Version => 3.0-beta1
2010-07-26 11:55 danboid Note Added: 0008653
2010-08-14 00:03 cth103 Note Added: 0008831
2010-08-14 00:03 cth103 Status new => resolved
2010-08-14 00:03 cth103 Resolution open => fixed
2010-08-14 00:03 cth103 Assigned To => cth103
2014-11-14 20:11 robertnyles Note Added: 0015975
2016-06-12 08:25 Some-E Note Added: 0018252
2016-06-12 08:25 Some-E Status resolved => feedback
2016-06-12 08:25 Some-E Resolution fixed => reopened
2016-10-19 10:51 robertnyles Note Added: 0018845
2016-10-31 14:58 cooltehno_bugs Note Added: 0018892
2019-05-30 11:10 x42 Relationship added has duplicate 0006882