View Issue Details

IDProjectCategoryView StatusLast Update
0001712ardourbugspublic2009-07-05 00:04
Reporterrotoquezada Assigned To 
Status resolvedResolutionno change required 
Product Version2.0 
Summary0001712: Mackie emulation with bcf2000 crashes ardour using alsa/sequencer ports
DescriptionAdded the suggested lines to ardour.rc but using alsa-sequencer instead of alsa-raw (... i don't always plug my usb controllers on the same order, that's why I can't use the raw ports ... I don't know which number my controllers will take)
On QjackCtl I can see the following IN/OUT ports on ardour:

If I attach port mcu to MIDI input 1 on the bcf2000 to ardour', I can move the bcf faders using the mixer strips on ardour as expected.
When I attach the midi output 1 of the bcf (which actually transmits data, I'm monitoring with aseqdump):
.- to the mcu port, nothing happens, I move a fader, nothing moves in ardour and when I release the fader it jumps back to tha last position set with ardour.
.- to the control port: same as above, nothing happens when moving faders
.- to the seq port: ardour's fader jumps when I move the bcf fader and then ardour freezes.

I tried the same procedure not connecting the ardour's mcu output port to the bcf's input, same problem
Tried also on revision 1810 of the 2.02 svn tree, same problem.

TagsNo tags attached.



2007-06-01 20:49

reporter   ~0004041

Yeah, if you doubt it the BCF2000 is in Logic Control mode.


2007-08-01 15:37

developer   ~0004212

There's an issue with alsa/sequencer ports and the mackie code. It looks like it's related to poll.

In the meantime, use alsa/raw ports.


2007-08-02 22:50

reporter   ~0004217

To automatically detect your BCF2000 on boot time (asuming you have it connected at boot) you can add these lines in your /etc/rc.local and access your raw midi device as /dev/snd/BCF2000:

    rm -f /dev/snd/BCF2000
    cd /proc/asound
    for card in card[0-9] ; do
    test "BCF2000" = `cat $card/id` && midi=`echo $card|sed 's/card/midi/g'` && ln -s /dev/snd/$midi /dev/snd/BCF2000


2009-07-05 00:04

manager   ~0006275

Since the design is to use alsa/raw ports as mentioned in the manual, this seems to be working as intended. Don't use alsa/sequencer ports with anything using the logic protocl, be it a BCF or Mackie. Resolving this issue out.

Issue History

Date Modified Username Field Change
2007-06-01 20:47 rotoquezada New Issue
2007-06-01 20:49 rotoquezada Note Added: 0004041
2007-08-01 15:37 panic Note Added: 0004212
2007-08-01 15:37 panic Status new => confirmed
2007-08-02 22:50 giso Note Added: 0004217
2009-07-05 00:04 seablade Note Added: 0006275
2009-07-05 00:04 seablade Status confirmed => resolved
2009-07-05 00:04 seablade Resolution open => no change required
2009-07-05 00:04 seablade Description Updated