View Issue Details

IDProjectCategoryView StatusLast Update
0001275ardourtranslationpublic2020-04-19 20:12
Reporterccomb Assigned Totaybin  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Summary0001275: untranslatable string
Descriptionin the file gtk2_ardour/ardour_ui.cc, around line 2043,
the following text is not l10n-compliant:


The following %1 %2 not in use and \n\
have been moved to:\n\
%3. \n\n\
Flushing the wastebasket will \n\
release an additional\n\
%4 %5bytes of disk space.\n"


The position of the adjective "following" in the sentence depends on the language.

The best solution here would be to use the gnu gettext plural-form feature.
http://www.gnu.org/software/libc/manual/html_node/Advanced-gettext-functions.html



TagsNo tags attached.

Activities

taybin

2006-11-02 04:27

administrator   ~0002551

I'm not sure what the problem is. The order of the %Ns can be rearranged in a translated string.

ccomb

2006-11-05 16:25

reporter   ~0002666

The very first problem in this string is that the translator does not know the meaning of %1 and %2. I always translate with a working version of ardour, but in a few cases I could not find the string in the UI. So I guessed that %1 is a number and %2 is "file was" or "files were". This first problem can be solved by adding an extractable comment in the code. But this is not enough.

The second (more important) problem is that the word "following" is not affected by the plural form in english while it is affected in other languages.
Here are the translations:
"The following 1 file is" => "Le fichier suivant ├ętait"
"The following 5 files were" => "Les 5 fichiers suivants ├ętaient"
In english, you only need 3 %N, in french you need 4 %N"


The last problem : since "file is" and "files were" are both individualy gathered as a single %N, the translator must translate "file is" and "files were" as is. This is not translatable in most languages, for example in turkish, where the verb "to be" is just a suffix appended to other words.
In french I can translate it, but when the sentence is reconstructed, it becomse invalid.

The real solution is to avoid using %N for something else than numbers, and to split the sentence in several forms.

seablade

2009-07-04 05:07

manager   ~0006232

Is this still an issue in newer versions of ardour(2.8 or later)?

ccomb

2009-07-14 15:31

reporter   ~0006432

Just checked against 2.8.1. The string is unchanged in the source code, and the translation issue is still the same.

seablade

2009-07-20 18:55

manager   ~0006445

Would you check against the newest SVN? I believe it is now fixed. Not sure if this fix will be in place for 2.8.2 but if not it will be in 2.8.3

     Seablade

paul

2009-07-20 20:17

administrator   ~0006446

I have altered the functions so that there are two messages, one for the plural case and one for singular. The only substitutions are now the number of files (for the plural case), the folder where the files are moved, and a number to indicate file/disk space. This can be found in svn rev 5397 and will be in 2.8.3 if it is confirmed that this fixes the basic issue.

ccomb

2009-12-06 23:54

reporter   ~0007242

I believe this is ok for most languages now, thanks for fixing.

cth103

2010-04-13 15:01

administrator   ~0007482

Reporter says this is fixed. Please re-open if there are still problems. Thanks!

system

2020-04-19 20:12

developer   ~0021485

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2006-10-13 23:51 ccomb New Issue
2006-11-02 04:27 taybin Note Added: 0002551
2006-11-02 04:28 taybin Status new => assigned
2006-11-02 04:28 taybin Assigned To => taybin
2006-11-02 05:26 taybin Relationship added has duplicate 0001110
2006-11-02 05:28 taybin Relationship deleted has duplicate 0001110
2006-11-02 05:32 taybin Status assigned => feedback
2006-11-05 16:25 ccomb Note Added: 0002666
2009-07-04 05:07 seablade Note Added: 0006232
2009-07-04 05:08 seablade Description Updated
2009-07-05 03:57 seablade Category other => translation
2009-07-14 15:31 ccomb Note Added: 0006432
2009-07-20 18:55 seablade Note Added: 0006445
2009-07-20 20:17 paul Note Added: 0006446
2009-12-06 23:54 ccomb Note Added: 0007242
2010-04-13 15:01 cth103 cost => 0.00
2010-04-13 15:01 cth103 Note Added: 0007482
2010-04-13 15:01 cth103 Status feedback => resolved
2010-04-13 15:01 cth103 Resolution open => fixed
2020-04-19 20:12 system Note Added: 0021485
2020-04-19 20:12 system Status resolved => closed