View Issue Details

IDProjectCategoryView StatusLast Update
0001193ardourbugspublic2009-10-28 22:23
ReporterMarianne Assigned To 
Status confirmedResolutionopen 
Product Version2.7 
Summary0001193: problems with non-english or rare characters
DescriptionI've been trying to run Ardour on my mac os X machine for quite some time and it wouldn't launch. I found out it was because it was located inside a folder (or path) containing characters that mac os X allows into paths but that many apps don't recognize - non-english characters, é è à ( ) [ ] / - and others like that. fortunately i ran it from the command prompt and saw what the error was but the avergae OS X user will not know about it, it would be a great idea to mention it on the mac os x page
TagsNo tags attached.


related to 0001483 closedtimbyr Tim's Tracking bug for proposed updates for 2.1 



2008-12-03 05:08

manager   ~0005438

While the characters [ and ] seem to be handled correctly now, I believe that adding a slash still screws with things because of its meaning in as far as directory structure. Confirmed still an issue in 2.7 native on OS X 10.4

Probably best just to search for unknown characters and inform the user that they need to not use those characters in my opinion, but I am not in charge of such decisions.



2009-07-04 22:53

manager   ~0006271

Updating to reflect 2.7 that I tested it in, I don't think it has changed. Though to be honest I am not sure thinking about it that a slash should matter, that always means a directory, and I am not sure that it should be handled differently in Ardour.


2009-07-05 00:13

administrator   ~0006276

this is now fixed in SVN and will be present in the upcoming 2.8.1 release.


2009-07-06 06:46

reporter   ~0006383

I tried revision 5328:

Right after compilation, the first attempt to create a new session "test123 / äöü" failed (something like unable to open directory), but that was not reproducible. Then everything else went fine, i.e., no failures any more.

Just one issue: When creating a snapshot with weired characters, only
the simplified name appears in the snapshot list. It would be great to
have the weired names there (otherwise it is not much better then
forbidding those weired names). Also in the "open recent" dialog only
the simplified names are shown. The ".ardour2/recent" file contains the
correct names. In the session files the correct names are stored.


2009-10-28 01:43

administrator   ~0006910

Bringing this out of feedback.

Issue History

Date Modified Username Field Change
2006-02-18 00:21 Marianne New Issue
2007-02-15 22:09 taybin Assigned To => taybin
2007-02-15 22:09 taybin Severity block => minor
2007-02-15 22:09 taybin Status new => acknowledged
2007-02-16 02:07 timbyr Relationship added related to 0001483
2008-12-03 05:08 seablade Note Added: 0005438
2008-12-03 05:09 seablade Status acknowledged => confirmed
2009-07-04 22:53 seablade Note Added: 0006271
2009-07-04 22:53 seablade Product Version 0.99 => 2.7
2009-07-05 00:13 paul Note Added: 0006276
2009-07-05 00:13 paul Status confirmed => feedback
2009-07-06 06:46 giso Note Added: 0006383
2009-10-28 01:43 cth103 Note Added: 0006910
2009-10-28 01:43 cth103 Assigned To taybin =>
2009-10-28 01:43 cth103 Status feedback => new
2009-10-28 22:23 cth103 Status new => confirmed