View Issue Details

IDProjectCategoryView StatusLast Update
0009530ardourbugspublic2024-01-03 09:31
Reporterfhomann Assigned Topaul  
Status closedResolutionfixed 
PlatformDebian GNUOSLinuxOS Version(any)
Product Version8.1 
Summary0009530: Launching clips with Launchpad Pro Mk3 stops working after a couple of triggers
DescriptionI can only use the Launchpad Pro Mk3 for a small number of clip trigger actions. Mostly 2-3, maybe sometimes 4-5. Any further attempt to trigger a clip will be ignored by Ardour. When I stop the transport triggering clips will work again for a small number of times.

When Ardour won't respond to button pushes on the Launchpad it isn't possible anymore to launch a clip per mouse click either.
Steps To Reproduce1. Create a track in the cue window
2. Fill up some slots with clips (I only used Ardour supplied drum Midi clips so far).

At this time I can trigger all the clips in the track by clicking their respective trigger icon (triangle)

With the Launchpad in Session Mode:

3. Push a button on the Launchpad to trigger a clip.
4. Push another button to trigger another clip.
5. Push yet another button to trigger another clip

After a couple of trigger button pushes on the Launchpad Ardour won't respond anymore to the trigger pushes. Moreover, as stated above, I won't be able to trigger any cue even per mouse click.
TagsNo tags attached.



2023-11-20 22:44

administrator   ~0028343

I am not able to reproduce this behavior.


2023-11-21 09:47

reporter   ~0028348

Hi Paul,
thanks for looking into this issue!
After reading your note I tried to eliminate everything else that might interfere with Ardour and the Launchpad. In the end I found that it is QJackCtl that somehow gets in the way: The behaviour I detailed above does only occur on my system when an instance of QJackCtl is also running.

That makes this issue itself solved, I guess. But there still is an issue with the interplay of QJackCtl and Ardour.
(My gut feeling is that it is QJackCtl doing wrong here since I have a couple of weird mostly minor issues with it since I transitioned my systems to pipewire.)

Again, thanks for caring!


2023-11-21 10:43

reporter   ~0028349

my last comment sadly seems to have been a bit premature. I had a couple of good runs without QJackCtl but now the issue is back again, even without QJackCtl running. So the only thing that has changed for me is that the issue is not always reproducible but only "almost always".

What can I do to dig deeper?


2024-01-03 09:29

reporter   ~0028441

No issues with 8.2 anymore. I've tested for a couple of days this time to prevent coming to yet another premature conclusion ;-)


2024-01-03 09:31

reporter   ~0028442

Solved/not reproducible as of Ardour 8.2.0

Issue History

Date Modified Username Field Change
2023-11-10 09:26 fhomann New Issue
2023-11-11 02:36 paul Assigned To => paul
2023-11-11 02:36 paul Status new => assigned
2023-11-20 22:44 paul Note Added: 0028343
2023-11-21 09:47 fhomann Note Added: 0028348
2023-11-21 10:43 fhomann Note Added: 0028349
2024-01-03 09:29 fhomann Note Added: 0028441
2024-01-03 09:31 fhomann Status assigned => closed
2024-01-03 09:31 fhomann Resolution open => fixed
2024-01-03 09:31 fhomann Note Added: 0028442