View Issue Details

IDProjectCategoryView StatusLast Update
0009282ardourbugspublic2023-03-22 18:29
ReporterSoundsOfKooky Assigned Tox42  
Status resolvedResolutionfixed 
PlatformArchOSLinuxOS Version(any)
Product Version7.3 
Summary0009282: Updating to 7.3 breaks tracks and busses using IEM plugins
DescriptionAfter updating to 7.3 all my projects using IEM plugins for ambisonics had no sound going through the tracks and busses with those plugins. I tried on new projects and the same happened.
Vanilla 4 channel with the default ardour 360° panner works, but as soon as I drop a IEM stereo Encoder, or a IEM binaural decoder somewhere there is no longer any sound coming through. All activity also stops on the meters, as if there were no audio on the track or being routed to the bus.
Note that this is also true when placing the plugins post-fader.

Reverting to 7.2 fixed the issue.
Steps To ReproduceRequires IEM plugin suite (v1.4.3 in my case)

1. create a 4 channel track
2. record some audio to it, or in a seperate track and drag it into the track
3. play it back: it works fine
4. disable panner: still works fine
5. add a stereo encoder plugin from IEM, set it to 1st order ambisonics (you might have to go into pin connections and manually remove the extra outputs that get automatically created, until you have only 4 outputs).
6. hit play. In 7.3 you'll get the bug: no sound, nothing on the meters

The same will happen on a bus, if you want to send audio from a 4channel ambisonics encoded track into a binaural decoder.
Tagsplugin, VST3



2023-03-21 01:41

administrator   ~0027483

Could you try with a recent nightly build (demo is fine for testing) from ?

Since those plugins are made with JUCE, a recent change made in Ardour likely addresses the issue:

If you wait for tomorrow's build (7.3.76), there is now also a context menu in the plugin-pinout window to allow to "disconnect all" which makes it easier to only connect the required I/O.
That seems to work here and the plugin also auto-detects 1st order when only connecting the first 4 outputs
IEM-decoder.png (88,414 bytes)   
IEM-decoder.png (88,414 bytes)   


2023-03-22 11:53

reporter   ~0027495

Tried build 7.3.77 :
-audio issue is fixed. Opening a project with IEM plugins works, no audio bug anymore
-disconnect all makes ardour freeze for a couple of seconds and crash, jack server is still running.


2023-03-22 18:28

administrator   ~0027496

> -disconnect all makes ardour freeze for a couple of seconds and crash

The crash happens inside the plugin. It is fine to either disconnect all inputs or all outputs for as long as there is at least one plugin I/O pin connected.
I have reported this issue:


2023-03-22 18:29

administrator   ~0027497

Thanks for testing.

Since "audio issue is fixed. Opening a project with IEM plugins works, no audio bug anymore" -- there is nothing more to do on the Ardour side of things.

Issue History

Date Modified Username Field Change
2023-03-15 15:51 SoundsOfKooky New Issue
2023-03-15 15:51 SoundsOfKooky Tag Attached: plugin
2023-03-15 15:51 SoundsOfKooky Tag Attached: VST3
2023-03-21 01:41 x42 Note Added: 0027483
2023-03-21 01:41 x42 File Added: IEM-decoder.png
2023-03-22 03:16 x42 Assigned To => x42
2023-03-22 03:16 x42 Status new => feedback
2023-03-22 11:53 SoundsOfKooky Note Added: 0027495
2023-03-22 11:53 SoundsOfKooky Status feedback => assigned
2023-03-22 18:28 x42 Note Added: 0027496
2023-03-22 18:29 x42 Status assigned => resolved
2023-03-22 18:29 x42 Resolution open => fixed
2023-03-22 18:29 x42 Note Added: 0027497