View Issue Details

IDProjectCategoryView StatusLast Update
0009205ardourbugspublic2023-01-24 17:44
ReporterSinuslabs Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
PlatformGNUOSLinuxOS Version(any)
Product Version7.2 
Summary0009205: Plugin crashes in Ardour with "X Error of failed request: BadWindow (invalid Window parameter)" on Plugin Scan
DescriptionHello Ardour Team,
I am a Plugin Developer who is also releasing on Linux. My Plugin runs fine but I have a customer reporting a issue with Ardour on VOID Linux. This crash is not happening in other DAWs only in Ardour. I am unable to reproduce this issue with my own System and do not know where to start to solve this. The customer is running X11.

The Plugin I am developing is open source and can be found here:

VST3 module-path '/home/rutsch/.vst3/Reach.vst3/Contents/x86_64-linux/'
[Info]: Scanning: /home/rutsch/.vst3/Reach.vst3
X Error of failed request: BadWindow (invalid Window parameter)
  Major opcode of failed request: 20 (X_GetProperty)
  Resource id in failed request: 0x0
  Serial number of failed request: 54
  Current serial number in output stream: 54
Scan Failed.
Steps To ReproduceAdd Plugin to .vst3 folder
Open Ardour in Void Linux
Scan Pluginins
Tags7.2, VST3, window, x11



2023-01-24 15:53

reporter   ~0027224

The problem was solved by the customer by installing the xsettingsd package and creating a empty config file. Afterwards Ardour was able to successfully scan the Plugin.


2023-01-24 16:06

administrator   ~0027225

Those errors typically happen when a thread that is not the main GUI thread attempts to draw.

Most/all applications on Linux use a single-threaded GUI (even when there are multiple other threads), and drawing from other threads will always cause issues.

Can you comment on whether or not this could be the case in your plugin?


2023-01-24 16:09

reporter   ~0027226

No my plugin is using a single thread for the GUI and runs the DSP on the other threads.


2023-01-24 17:44

administrator   ~0027229

Your plugin works without errors here on my system (Debian 11). The issue would appear to be user-specific.

Issue History

Date Modified Username Field Change
2023-01-24 15:07 Sinuslabs New Issue
2023-01-24 15:07 Sinuslabs Tag Attached: 7.2
2023-01-24 15:07 Sinuslabs Tag Attached: VST3
2023-01-24 15:07 Sinuslabs Tag Attached: window
2023-01-24 15:07 Sinuslabs Tag Attached: x11
2023-01-24 15:53 Sinuslabs Note Added: 0027224
2023-01-24 16:06 paul Note Added: 0027225
2023-01-24 16:09 Sinuslabs Note Added: 0027226
2023-01-24 17:44 paul Note Added: 0027229