View Issue Details

IDProjectCategoryView StatusLast Update
0009081ardourbugspublic2022-12-13 13:38
Reporterstefan-franz Assigned Tox42  
Status closedResolutionnot fixable 
PlatformUbuntuOSLinuxOS Version(any)
Product Version7.1 
Summary0009081: Speedrum Light file requester opens in the Flatpak version - but not in the actual .run version of Ardour 7.1
DescriptionHello, my System: Linux Mint 21 Cinnamon.
Speedrum light has a function to save complete drumsets incl samples. The file requester opens with the flatpak version of linux mint. Today i installed the actual .run version, and with this, no file requester opens. Otherwise this plugin works normal.

I installed the vst3 version here: /usr/lib/lxvst3
Steps To ReproduceClick to load or save a drumset - and you see no file requester. (look to my screenshot)
TagsNo tags attached.



2022-11-08 14:09



2022-11-09 09:27

reporter   ~0026871

I can confirm the same in Ubuntu22.04, Ardour 7.1, speedrum light LXVST.


2022-11-09 09:28

administrator   ~0026872

> I installed the vst3 version here: /usr/lib/lxvst3

This is not a valid location, please see

try /usr/lib/vst3/ or $HOME/.vst3/


2022-11-09 09:31

administrator   ~0026873

Last edited: 2022-11-09 09:32

Assuming they use an old version of JUCE, may be relevant.


2022-11-09 10:40

reporter   ~0026874

> try /usr/lib/vst3/
Tested. Same issue. Also anywhere in the $HOME/.vst3/

btw: in the $HOME/.vst3/presets - Ardour saves the presets of the vst plugins.

And here expects Ardour the plugins:

i have a fully and fresh Mint 21 all updated on my Desktop and my Laptop - and on all 2 machines the same: Flatpak Version works, the .run version not.
Error must be on Ardour (missing rights that plugins are allowed to open the file requester or whatever).


2022-11-09 10:45

reporter   ~0026875

...can not edit my entry so a new....

Where does Ardour expect VST3 plugins via default?
In the manual it's not mentionend. I add the path of course in the VST settings, but that would be useful, if the manual gets here an information.


2022-11-19 10:48

reporter   ~0026904

Additional info: Surge XT (Synthesizer)
has on option "File load from disk" - there is also no file requester window that opens


2022-11-20 04:39

administrator   ~0026910

Works fine in my local build. I will check the official nightly build tomorrow.


2022-11-20 08:06

reporter   ~0026913

Thanks for checking.

I have the normal build installed (not nightly). To be on the safe side, i explain it again: Surge Top middle load / right side "Functions / load patch from file" - i expect a file requester where i can select an sound / patch saved anywhere on my disc.

If on your system all works fine, then the reason in my opinion is the install routine / system on Linux Mint 21 Cinnamon.
As mentioned, the Flatpak version works right and bring the file requester - only the official download version 7.1.0 has that problem.
The issue is on 3 different machines - so i would say a general problem.


2022-11-21 09:35

reporter   ~0026919

I bought now the big brother of Speedrum and the same issue. No file requester windows open if i want to load drumsets.


2022-11-25 07:01

reporter   ~0026943

I use the Redux Sampler and there is a function in the sound explorer inside of Redux called "reveal in file explorer" - that also doesn't work (i expect that the file requester of linux opens if i click on it). So i mean all file requester open commands (to open the linux Nemo file explorer) from plugins, are not running


2022-12-13 11:01

reporter   ~0027034

Here on 7.2 - still not working - Linux Mint 21 Cinnamon


2022-12-13 12:24

reporter   ~0027035

On Debian 11, KDE Plasma, the load patch file dialog works without issues. Surge XT as a plugin in Ardour and as well as standalone.

What happens, if running Surge XT standalone and trying to open a patch file?


2022-12-13 12:32

reporter   ~0027036

Thanks for checking - i don't use Surge

But, you can try out Speedrum light - freeware - it has the same function.

BTW - the problem is at all my devices. Linux Mint 21 Cinnamon


2022-12-13 12:39

reporter   ~0027037

I meant - i don't use surge anymore - but some entrys above you see, that surge also not worked in Ardour.


2022-12-13 12:41

reporter   ~0027038

Did you test with Speedrum standalone? And check maybe with Speedrum on AV Linux, so you can exclude it's a distro thing. Eventually some library constellation is the culprit. Maybe the same on Ubuntu as cooltehno mentioned.

On pure Debian it seems to work sans problems apparently.


2022-12-13 12:41

administrator   ~0027039

Perhaps ?

A workaround for this is presented at


2022-12-13 12:52

reporter   ~0027040

Checked with AV Linux and Ubuntu Studio. No file reqester opens on both at Speedrum Load a new kit or save a new kit.
As mentioned, it worked with the Flatpak version of Ardour 7.1 - i saved 1 kit and all worked. Maybe that helps you.


2022-12-13 12:58

reporter   ~0027041

Yes, as x42 linked to those URLs in his comment, it seems to be a GTK2/GTK3 framework thing, constellating with Zenity, check his links. And self-built Ardour doesn't have this problem, that's why it doesn't occur here apparently.


2022-12-13 13:10

reporter   ~0027042

hmmm...i'm a bit overwhelmed...

You mean as workaroung this:

To elaborate zenity is a gtk3 application, while Ardour is a gtk2 app and binaries from come with gtk2 that's in LD_LIBRARY_PATH.

A quick/dirty solution: add /usr/local/bin/zenity or ~/bin/zenity:

exec /usr/bin/zenity "$@"

I checked and see Zenity is installed. What do i have now to do? Creating that path: /usr/local/bin/zenity and then?


2022-12-13 13:17

reporter   ~0027043

Don't worry - I didn't fully understand as well, I ended up as well at that point. But as it's not relevant for me, I didn't follow the path :)

Let me check, eventually I get it.


2022-12-13 13:27

reporter   ~0027044

I now think it was rather a workaround for the plugin developers, if I'm not mistaken.


2022-12-13 13:32

reporter   ~0027045

now it works - i added it to my manual for new users / newbies like me


2022-12-13 13:34

reporter   ~0027046

It wasn't for the devs, I got it finally ;)

You added the script to /usr/loca/bin?


2022-12-13 13:35

reporter   ~0027047

Thanks to Robin for your great support und awesome knowledge


2022-12-13 13:37

administrator   ~0027048

@mikelupe - it is a workaround for users. Plugin devs are not supposed to rely on external applications (which may or may not exist) nor launch external apps to begin with (it is not rt-safe to fork)

so tl;dr: There is nothing we can do about. The onus of the plugin developer to fix this.


2022-12-13 13:37

reporter   ~0027049

@mike - yes that was the solution.

Issue History

Date Modified Username Field Change
2022-11-08 14:09 stefan-franz New Issue
2022-11-08 14:09 stefan-franz File Added: Bildschirmfoto vom 2022-11-08 14-51-56.jpg
2022-11-09 09:27 cooltehno_bugs Note Added: 0026871
2022-11-09 09:28 x42 Note Added: 0026872
2022-11-09 09:31 x42 Note Added: 0026873
2022-11-09 09:32 x42 Note Edited: 0026873
2022-11-09 10:40 stefan-franz Note Added: 0026874
2022-11-09 10:45 stefan-franz Note Added: 0026875
2022-11-19 10:48 stefan-franz Note Added: 0026904
2022-11-20 04:39 paul Note Added: 0026910
2022-11-20 08:06 stefan-franz Note Added: 0026913
2022-11-21 09:35 stefan-franz Note Added: 0026919
2022-11-25 07:01 stefan-franz Note Added: 0026943
2022-12-13 11:01 stefan-franz Note Added: 0027034
2022-12-13 12:24 mikelupe Note Added: 0027035
2022-12-13 12:32 stefan-franz Note Added: 0027036
2022-12-13 12:39 stefan-franz Note Added: 0027037
2022-12-13 12:41 mikelupe Note Added: 0027038
2022-12-13 12:41 x42 Note Added: 0027039
2022-12-13 12:52 stefan-franz Note Added: 0027040
2022-12-13 12:58 mikelupe Note Added: 0027041
2022-12-13 13:10 stefan-franz Note Added: 0027042
2022-12-13 13:17 mikelupe Note Added: 0027043
2022-12-13 13:27 mikelupe Note Added: 0027044
2022-12-13 13:32 stefan-franz Note Added: 0027045
2022-12-13 13:34 mikelupe Note Added: 0027046
2022-12-13 13:35 stefan-franz Note Added: 0027047
2022-12-13 13:37 x42 Note Added: 0027048
2022-12-13 13:37 stefan-franz Note Added: 0027049
2022-12-13 13:38 x42 Assigned To => x42
2022-12-13 13:38 x42 Status new => closed
2022-12-13 13:38 x42 Resolution open => not fixable