View Issue Details

IDProjectCategoryView StatusLast Update
0008939ardourbugspublic2022-07-09 20:34
ReporterNonlinear Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status newResolutionopen 
PlatformMicrosoftOSWindowsOS Version10
Product Version6.9 
Summary0008939: Some VST3 plugins produce no output - ALL VST3 plugins show I/O error in plugin manager
DescriptionEvery VST3 plugin I have checked in Ardour's plugin manager shows the following errors:

[Info]: VST3: \ error getting busInfo for bus: 0 rv: 0, got type: kMain
[Info]: VST3: \ error getting busInfo for bus: 0 rv: 0, got type: kMain

Some VST3 plugins work properly while others receive input but produce no output back to the DAW - like they are perpetually bypassed. They LOOK like they are working (their meters move, etc.) but the processed sound is not returned to the DAW.

VST2 versions of the same plugins work properly.
Steps To Reproduce0000001) Scan plugin in plugin manager and view report. (All VST3 plugins report I/O bus errors.)
#2) Insert VST3 plugin in any track or bus and listen for output change when turning knobs, etc. (Some plugins work, some don't.)
TagsNo tags attached.

Activities

Nonlinear

2022-07-09 20:34

reporter   ~0026499

There appears to be no way to edit my post so I will add info here. This issue is with regard to 3rd party VST3 plugins - of all brands. Some work some don't but ALL report the I/O error. The reason I marked this "major" is because a user can inadvertently think the plugin is working when it is in fact not affecting the audio at all.

Issue History

Date Modified Username Field Change
2022-07-09 20:27 Nonlinear New Issue
2022-07-09 20:34 Nonlinear Note Added: 0026499