View Issue Details

IDProjectCategoryView StatusLast Update
0008889ardourbugspublic2022-05-10 06:36
Reportermrshroomy Assigned Topaul  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformArchOSLinuxOS Version(any)
Product Version6.9 
Summary0008889: Arch Linux has no sound playback when Ardour is exporting a song
DescriptionWhen i use latest arch linux Ardour with pipewire-jack (Wireplumber session manager) and 1024 samples and export a song, i can't hear anything im listening to like Discord voice or music when the song is exporting. When it has finished exporting i hear playback normally again
Steps To Reproduce1. Start Ardour
2. Record sound or midi in Ardour
3. Export the song
4. No sound is playback on Linux when its exporting
Tagsexport

Activities

x42

2022-03-22 18:33

administrator   ~0026350

Ardour uses "freewheeling" to export.
It asks JACK to disconnect from the audio hardware and run as fast as possible and as slow as necessary. This was no dropouts can happen during export and it is usually also faster than wall-clock time.

I do now know how pipewire handles things, but with JACK this is expected behavior. All JACK applications cannot use hardware I/O while jack is freewheeling.

paul

2022-04-16 00:33

administrator   ~0026387

If you do not want this behavior, do not use JACK. We generally recommend against the use of JACK, particularly by new users, unless there is an actual need for it.

This is not behavior that we will change. If you use the JACK backend, the only way to reliably perform a faster-than-realtime export is to use freewheeling, which will necessarily silence all JACK output to your audio (and MIDI) hardware. That is by design, and isn't a part of Ardour.

Unless you need JACK, you should use Ardour's ALSA backend (which disconnects from the audio hardware entirely during faster-than-realtime export.

Issue History

Date Modified Username Field Change
2022-03-19 13:02 mrshroomy New Issue
2022-03-19 13:02 mrshroomy Tag Attached: export
2022-03-22 18:33 x42 Note Added: 0026350
2022-04-16 00:33 paul Note Added: 0026387
2022-04-16 00:34 paul Assigned To => paul
2022-04-16 00:34 paul Status new => resolved
2022-04-16 00:34 paul Resolution open => no change required