View Issue Details

IDCategoryLast Update
0008756bugs2021-06-23 07:20
ReporterCTSAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformArchOSLinuxOS Version(any)
Product Version6.7 
Fixed in Version 
Summary0008756: Removing VST2 plugin with MIDI mapped parameter crashes Ardour
DescriptionOnly seems to be an issue with VST2, I tried to reproduce with a few different VST2, LV2 and VST3 plugins.
Steps To Reproduce1. Load a VST2 plugin on a track
2. Open the generic UI and use the MIDI learn function to map a parameter to a midi controller
3. Delete the plugin from the track -> seg fault!
Additional InformationArdour version 6.7.200
TagsNo tags attached.

Activities

x42

2021-06-21 01:41

administrator   ~0025977

Sadly I cannot reproduce this crash.
Does it happen with every VST2? Can you get a backtrace -- see https://ardour.org/debugging_ardour

CTS

2021-06-21 02:32

reporter   ~0025978

Backtrace here: https://pastebin.com/zJTXMAdi

Happens with Harrison AVA LegacyQ plugin. I've tested a bit more and noticed that it seems to only happen if I use the delete key "the first time" I try to delete the plugin. If I add the plugin, map the parameter, then right click on the plugin and select "Delete" then all is well. Furthermore, if I then add the plugin and map the parameter again after that, deleting with the "Delete" key works fine. So I would update my steps to reproduce to:
- Start ardour
- add the plugin
- map the parameter
- then use the delete key to delete the plugin

x42

2021-06-21 03:28

administrator   ~0025979

Can you test if 6.7-209-gdb1821a363 fixes the issue?

This requires feedback to be enabled, and you have to be lucky that ardour tries to send feedback to the ctrl surface just after the plugin was removed.
I have not been able to reproduce it, but the backtrace was very helpful. Thanks!

CTS

2021-06-22 07:23

reporter   ~0025989

I just tried commit 96febb8f266e7dad8b6426b7dd0d7ebc3d6e87c7 and now there appears to be seg faults and bus errors (I have encountered both running these steps over and over) preventing me from testing this thoroughly. Somehow with this new issue I can't get a backtrace either since it locks up my whole system when running in gdb and I can't do anything but restart the computer.

Steps to reproduce here:
1. Start Ardour
2. under preferences enable Generic MIDI control
3. Click Show Protocol Settings and select "Virtual Keyboard" for Incoming MIDI. Feedback can be left enabled or disabled - doesn't seem to stop crashes for me.
4. Open the Virtual Keyboard window
5. Add a VST plugin to a track.
6. Open the generic UI and map any control to a controller on the virtual keyboard. I've been using the mod wheel.
7. Delete the plugin from the track
8. Repeat steps 5 to 7 until Ardour crashes. (Only takes 2 or 3 repeats max for me to crash ardour reliably)

x42

2021-06-23 02:03

administrator   ~0026000

Yet another crash fixed in 6.7-214-g8ad1405cf5.

Happened when deleting a plugin within 30 sec after using MIDI learn.

CTS

2021-06-23 07:20

reporter   ~0026001

Put it through its paces today and the latest commit seems rock solid to me. Thank you for addressing this so quickly!

Issue History

Date Modified Username Field Change
2021-06-21 01:24 CTS New Issue
2021-06-21 01:41 x42 Note Added: 0025977
2021-06-21 02:32 CTS Note Added: 0025978
2021-06-21 03:28 x42 Assigned To => x42
2021-06-21 03:28 x42 Status new => feedback
2021-06-21 03:28 x42 Note Added: 0025979
2021-06-22 07:23 CTS Note Added: 0025989
2021-06-22 07:23 CTS Status feedback => assigned
2021-06-23 02:03 x42 Note Added: 0026000
2021-06-23 02:09 x42 Status assigned => feedback
2021-06-23 07:20 CTS Status feedback => closed
2021-06-23 07:20 CTS Resolution open => fixed
2021-06-23 07:20 CTS Note Added: 0026001