View Issue Details

IDCategoryLast Update
0008748bugs2021-06-16 17:25
ReporterM.F.Assigned To 
Reproducibilityrandom 
Status newResolutionopen 
PlatformDebian GNUOSLinuxOS Version(any)
Product Version6.7 
Fixed in Version 
Summary0008748: Crash when switching snapshots
DescriptionCrash when switching between snapshots

message: SessionName did not load succesfully. Port registration failed.
- error: unable to create port 'LTC in' : failed constructor.

Jack used, when using plain Alsa problem disappeared
TagsNo tags attached.

Activities

x42

2021-06-16 15:37

administrator   ~0025963

Does this always happen, or only with a specific session or snapshot?

1. Create a new session
2. Snapshot (& keep working on current version)
3. Load new snapshot (via Editor's right sidebar)
4. Reload previous snapshot

works fine here. Had to dust off JACK for the test, tried with jackdmp 1.9.17.

If only a specific snapshot causes it, could you attach the .ardour session file?

M.F.

2021-06-16 17:25

reporter   ~0025964

Had it happen in two different sessions but now I'm not having any crashes at all. I tried those sessions as well created some for test purposes but no issues. Weird.

Issue History

Date Modified Username Field Change
2021-06-16 15:18 M.F. New Issue
2021-06-16 15:37 x42 Note Added: 0025963
2021-06-16 17:25 M.F. Note Added: 0025964