View Issue Details

IDCategoryLast Update
0008745bugs2021-07-02 17:54
ReporterDaniDeSaroAssigned Topaul 
Reproducibilitysometimes 
Status resolvedResolutionfixed 
PlatformGNUOSLinuxOS Version(any)
Product Version6.7 
Fixed in Version 
Summary0008745: Incomplete midi file import
DescriptionWhen a midi file is exported from the EZdrummer plugin and imported into Ardor on a track, the midi file is incomplete, lacking bars relative to the exported midi file. When importing the same file into the EZdrummer plugin, the midi file is displayed complete.
Steps To Reproduce1. Open the EZdrummer plugin.
2. Go to "Browser" tab
3. Drag multiple MIDI blocks onto the EZdrummer play track.
4. Export said track as a midi file to a system folder
5. Import the midi file to an Ardor track from the 'Session> Import' menu
So you can see that the number of bars is less than the midi file exported from EZdrummer.
6. If the midi file is imported into the EZdrummer plugin, it is displayed with all bars, without errors.
Additional Informationhttps://discourse.ardour.org/t/incomplete-midi-file-import/106084
TagsNo tags attached.

Activities

DaniDeSaro

2021-06-15 21:08

reporter  

parte1.mid (3,043 bytes)

paul

2021-06-22 00:43

administrator   ~0025988

Last edited: 2021-06-22 00:58

View 2 revisions

As a note: this MIDI file contains illegal SMF Meta events. It also contains interesting arrangements, such as notes that span time signature changes.

These are not necessarily the cause of the issue, but EZ Drummer is not generating well-formed a well formed SMF here.

paul

2021-06-22 20:19

administrator   ~0025992

last comment was incorrect! serious bug in the library we use for parsing SMF.

now fixed, as of commit 336319a1d and fix upstreamed to libsmf (though that project is effectively frozen in time)

DaniDeSaro

2021-06-26 09:39

reporter   ~0026008

What can I do now to use the "import" function without errors? Is there a patch, or are you going to include the fix in a new version of Ardor? Thank you very much for your work, greetings Paul

paul

2021-06-26 14:41

administrator   ~0026010

It's in the nightly builds at nightly.ardour.org; it will be in the next release (out next week); the change can be found in the git repository using the commit hash ("id") shown in my comment.

DaniDeSaro

2021-06-26 21:51

reporter   ~0026012

very thanks!

paul

2021-07-02 15:57

administrator   ~0026022

All bugs go here (tracker.ardour.org). The nightlies are not "supported" in the sense that we have not released them, so bugs are more likely there than in releases. But since they are "work in progress", we certainly want to hear about problems whether they exist in the last release or a current nightly build.

DaniDeSaro

2021-07-02 17:54

reporter   ~0026023

OK thank you. In the next few hours I will make you a new report. All the best.

Issue History

Date Modified Username Field Change
2021-06-15 21:08 DaniDeSaro New Issue
2021-06-15 21:08 DaniDeSaro File Added: parte1.mid
2021-06-15 21:43 paul Assigned To => paul
2021-06-22 00:34 paul Status new => acknowledged
2021-06-22 00:43 paul Note Added: 0025988
2021-06-22 00:58 paul Note Edited: 0025988 View Revisions
2021-06-22 20:19 paul Status acknowledged => resolved
2021-06-22 20:19 paul Resolution open => fixed
2021-06-22 20:19 paul Note Added: 0025992
2021-06-26 09:39 DaniDeSaro Note Added: 0026008
2021-06-26 14:41 paul Note Added: 0026010
2021-06-26 21:51 DaniDeSaro Note Added: 0026012
2021-07-02 15:57 paul Note Added: 0026022
2021-07-02 17:54 DaniDeSaro Note Added: 0026023