View Issue Details

IDCategoryLast Update
0008742bugs2021-06-14 00:36
ReporterLPJAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformDebian GNUOSDebianOS Version10 stable
Product Version6.7 
Fixed in Version 
Summary0008742: Channels out of sync after export
DescriptionSeveral songs with multiple tracks in a long project.
Songs split by means of range markers.
Export -> select ranges in the "Time Span" tab.
When exporting, Log Button flashes red light.
Listening to the exported tracks, some songs (not all) are out of sync.
Checking the original project in Ardour everything looks OK.
Exporting each range (song) separately everything is OK.
I have tried exporting to various file formats and, more or less, the same thing happens.
I have also tried deactivating the plugins, but the error is reproduced.
Steps To ReproduceEvery time it happens
Additional InformationArdour log:

2021-06-13T20:29:57 [INFO]: AlsaAudioBackend: adjusted output channel count to match device.
2021-06-13T20:29:57 [INFO]: AlsaAudioBackend: adjusted input channel count to match device.
2021-06-13T20:29:59 [INFO]: harvid version: 803
2021-06-13T20:30:00 [INFO]: Cargando menĂºs desde /opt/Ardour-6.7.0/etc/ardour.menus
2021-06-13T20:30:01 [INFO]: Loading user ui scripts file /home/ni/.config/ardour6/ui_scripts
2021-06-13T20:30:01 [INFO]: Loading plugin order file /home/ni/.config/ardour6/plugin_metadata/plugin_order
2021-06-13T20:30:01 [INFO]: Loading history from /home/ni/ARDOUR Media/DEMO PAL DISCO/DEMO PAL DISCO.history
2021-06-13T20:30:17 [INFO]: Searching for export formats in /home/ni/.config/ardour6/export:/opt/Ardour-6.7.0/share/export
2021-06-13T20:30:45 [ERROR]: DiskReader player:VOZ MARIA: when refilling, cannot write 516096 into buffer
2021-06-13T20:31:07 [ERROR]: DiskReader player:VOZ MARIA: when refilling, cannot write 516096 into buffer
2021-06-13T20:31:07 [ERROR]: DiskReader player:KOROS (DUPLICADA): when refilling, cannot write 516096 into buffer
2021-06-13T20:31:07 [ERROR]: DiskReader player:KORO ARMONIA: when refilling, cannot write 516096 into buffer
2021-06-13T20:31:37 [ERROR]: DiskReader player:VOZ MARIA: when refilling, cannot write 516096 into buffer
2021-06-13T20:32:22 [ERROR]: DiskReader player:VOZ MARIA: when refilling, cannot write 516096 into buffer
2021-06-13T20:32:22 [ERROR]: DiskReader player:KOROS: when refilling, cannot write 516096 into buffer
2021-06-13T20:32:22 [ERROR]: DiskReader player:KOROS (DUPLICADA): when refilling, cannot write 516096 into buffer
2021-06-13T20:32:37 [INFO]: Writing Mixer Screenshot: /home/ni/ARDOUR Media/DEMO PAL DISCO/export/JAILS-mixer.png.
2021-06-13T20:32:38 [INFO]: Copying Mixer Screenshot: /home/ni/ARDOUR Media/DEMO PAL DISCO/export/SNAKES-mixer.png.
2021-06-13T20:32:38 [INFO]: Copying Mixer Screenshot: /home/ni/ARDOUR Media/DEMO PAL DISCO/export/MARCH-mixer.png.
2021-06-13T20:32:38 [INFO]: Copying Mixer Screenshot: /home/ni/ARDOUR Media/DEMO PAL DISCO/export/SAVAGE-mixer.png.
2021-06-13T20:32:38 [INFO]: Copying Mixer Screenshot: /home/ni/ARDOUR Media/DEMO PAL DISCO/export/LOST-mixer.png.
2021-06-13T20:32:38 [INFO]: Copying Mixer Screenshot: /home/ni/ARDOUR Media/DEMO PAL DISCO/export/VOYEUR-mixer.png.
2021-06-13T20:32:38 [INFO]: Copying Mixer Screenshot: /home/ni/ARDOUR Media/DEMO PAL DISCO/export/BUCKETHEAD-mixer.png.
2021-06-13T20:32:38 [INFO]: Copying Mixer Screenshot: /home/ni/ARDOUR Media/DEMO PAL DISCO/export/CRAZY HORSE-mixer.png.
2021-06-13T20:32:39 [INFO]: Writing Export Analysis Image: /home/ni/ARDOUR Media/DEMO PAL DISCO/export/BUCKETHEAD.png.
2021-06-13T20:32:40 [INFO]: Writing Export Analysis Image: /home/ni/ARDOUR Media/DEMO PAL DISCO/export/CRAZY HORSE.png.
2021-06-13T20:32:41 [INFO]: Writing Export Analysis Image: /home/ni/ARDOUR Media/DEMO PAL DISCO/export/JAILS.png.
2021-06-13T20:32:42 [INFO]: Writing Export Analysis Image: /home/ni/ARDOUR Media/DEMO PAL DISCO/export/LOST.png.
2021-06-13T20:32:43 [INFO]: Writing Export Analysis Image: /home/ni/ARDOUR Media/DEMO PAL DISCO/export/MARCH.png.
2021-06-13T20:32:44 [INFO]: Writing Export Analysis Image: /home/ni/ARDOUR Media/DEMO PAL DISCO/export/SAVAGE.png.
2021-06-13T20:32:45 [INFO]: Writing Export Analysis Image: /home/ni/ARDOUR Media/DEMO PAL DISCO/export/SNAKES.png.
2021-06-13T20:32:47 [INFO]: Writing Export Analysis Image: /home/ni/ARDOUR Media/DEMO PAL DISCO/export/VOYEUR.png.
TagsNo tags attached.

Activities

LPJ

2021-06-13 19:09

reporter  

LPJ

2021-06-13 19:20

reporter   ~0025953

Tested export formats:
-Wav 44.1, 16
-MP3 extreme, session rate

Export is NOT in real time

x42

2021-06-13 19:37

administrator   ~0025954

Could you attach the .ardour session file?

Are there perhaps any latent plugins which are automated (variable latency)?

Those DiskReader warnings are not normal and likely the cause. It's however unclear why that happens at all.

LPJ

2021-06-13 20:00

reporter   ~0025956

I try to attach the .ardour file, but it takes 3.1 MB and the web does not support it.
How can I share it?

LPJ

2021-06-13 20:47

reporter   ~0025957

Backend used is ALSA

x42

2021-06-13 22:04

administrator   ~0025958

> I try to attach the .ardour file, ...

Do you have access to dropbox or a similar service?

Does this only happen when you export multiple timespans, and the first timespan is fine, but later ones are not?

x42

2021-06-13 22:34

administrator   ~0025959

Reproduced It happens when two consecutive export ranges overlap marginally:

Range A start | Range B start | Range A end | Range B end

x42

2021-06-14 00:36

administrator   ~0025960

Previous assessment was incorrect .It can also happen with non overlapping ranges.

Fixed in 6.7-173-g21f4598395

Issue History

Date Modified Username Field Change
2021-06-13 19:09 LPJ New Issue
2021-06-13 19:09 LPJ File Added: Captura de pantalla -2021-06-13 20-33-34.png
2021-06-13 19:20 LPJ Note Added: 0025953
2021-06-13 19:37 x42 Note Added: 0025954
2021-06-13 20:00 LPJ Note Added: 0025956
2021-06-13 20:47 LPJ Note Added: 0025957
2021-06-13 22:04 x42 Note Added: 0025958
2021-06-13 22:34 x42 Note Added: 0025959
2021-06-14 00:36 x42 Note Added: 0025960
2021-06-14 00:36 x42 Assigned To => x42
2021-06-14 00:36 x42 Status new => resolved
2021-06-14 00:36 x42 Resolution open => fixed