View Issue Details

IDProjectCategoryView StatusLast Update
0008736ardourbugspublic2023-12-06 00:47
ReporterSitruc55 Assigned Tox42  
Status resolvedResolutionduplicate 
Platformx86OSFedoraOS Version34
Product Version6.7 
Summary0008736: MIDI Import hangs
DescriptionWhen trying to import any midi file Ardour hangs upon starting import. Preview of the midi file works fine
Steps To ReproduceStart new project and try to import midi file
Additional InformationNothing in log file. Must force terminate Ardour to recover
TagsNo tags attached.


duplicate of 0008738 closedpaul GUI freezes when adding MIDI track 



2021-06-09 01:39

administrator   ~0025929

Importing MIDI files works just fine here. Is this specific to a given .mid file, and if so, can you share that?
What synth do you use when importing MIDI files? Perhaps the issue at hand is the synth plugin?


2021-06-09 02:05

reporter   ~0025930

It hangs at the import progress dialog pop-up with no progress shown. Clicking on cancel does nothing and I have to hard terminate Ardour 6.7.
I've tried several different midi files and synths (sfizz, ACE Reasonable synth, ACE fluid synth). Just now I tried to import cest-si-bon.midi using the default ACE Reasonable Synth and it hung-up. I've attached that midi file.
Could this be pipewire 0.3.29 related? There's nothing strange about my set-up and it use to work fine. I also see this in the system log file:

6/8/21 7:02 PM pipewire protocol-native 0x55d3146f8e40: client 0x55d31483e860 error -22 (Invalid argument)

followed by hundreds or more of:

6/8/21 7:04 PM localhost plasmashell[9080] Command [V,R,I,A]:


2021-06-09 02:26

administrator   ~0025931

The file imports just fine here (using general MIDI synth which comes with Ardour from

So either it is indeed PW related, easy to test try Ardour/ALSA or a Pulseaudio, or perhaps some issue with your Ardour built. Is that the official binary from
midi_import.png (158,119 bytes)   
midi_import.png (158,119 bytes)   


2021-06-09 03:28

reporter   ~0025932

I got Ardour 6.7 from the RPM in the
Fedora jam 34 repository. I don't seem to have the alsa-backend available at the moment, will look into it tomorrow. From the log error it seems to be pw related, I could try to submit an bug report with them. Thanks


2021-06-09 14:35

administrator   ~0025934

It's an odd choice but Fedora packages Ardour backends (ALSA, Dummy, JACK, etc) separately.
Trying without pipewire first is a good idea. If that works then yes it's a PW issue.


2021-06-09 17:06

reporter   ~0025935

I'm unable to select the alsa-backend

I found what looks like a related issue on pipewire I added a comment to end linking in this report:


2021-06-09 20:11

administrator   ~0025938

see also which is apparently fixed in pipewire v0.3.30.

Issue History

Date Modified Username Field Change
2021-06-08 01:20 Sitruc55 New Issue
2021-06-09 01:39 x42 Note Added: 0025929
2021-06-09 01:39 x42 Status new => feedback
2021-06-09 02:05 Sitruc55 File Added: Cest-si-bon.midi
2021-06-09 02:05 Sitruc55 Note Added: 0025930
2021-06-09 02:05 Sitruc55 Status feedback => new
2021-06-09 02:26 x42 File Added: midi_import.png
2021-06-09 02:26 x42 Note Added: 0025931
2021-06-09 03:28 Sitruc55 Note Added: 0025932
2021-06-09 14:35 x42 Note Added: 0025934
2021-06-09 17:06 Sitruc55 Note Added: 0025935
2021-06-09 20:09 x42 Relationship added duplicate of 0008738
2021-06-09 20:11 x42 Note Added: 0025938
2021-06-09 20:11 x42 Status new => feedback
2023-12-06 00:47 x42 Assigned To => x42
2023-12-06 00:47 x42 Status feedback => resolved
2023-12-06 00:47 x42 Resolution open => duplicate