View Issue Details

IDProjectCategoryView StatusLast Update
0008730ardourbugspublic2021-05-30 04:11
Reportergaryd Assigned To 
Status newResolutionopen 
PlatformDebian GNUOSLinuxOS Version(any)
Product VersionMixbus 7.x 
Summary0008730: Fatal Error when selecting routes via Lua
DescriptionMixbus32c v7.0 and Ardour v6.7

Using the script in Steps below causes a Fatal Error crash saying "programming error: unknown selectable type passed to Selection:add()".

According to the manual’s Lua class reference, RouteTimeAxisView is a RouteUI which is a Selectable which is what set_selection() requires. So this error was unexpected.

Robin Gareus commented that the script looks correct, which suggests that this is a bug in Ardour.

I also tried with the "ArdourUI.SelectionOp.Add" parameter value which had the same result, only this time the error message said "Add()" instead of "add()".
Steps To ReproduceIn the Lua script window...

local r = Session:route_by_name(“route name here”)
local rtav = Editort:rtav_from_route(r)
local sl = ArdourUI.SelectionList()
Editor:set_selection(sl, ArdourUI.SelectionOp.Set)
TagsNo tags attached.



2021-05-30 04:11

reporter   ~0025912

A further comment from Robin in the discourse topic...

"I just realized that Editor:set_selection is exclusively for items that are only visible on the editor-timeline.
Track/Bus selection is synced with the Mixer and control-surfaces.
It is not currently possible to select track from Lua scripts, and there are some technical issues with exposing that API."

So, not a bug after all by the sounds of it.

P.S. The script has a typo - "Editort" - here and in the discourse topic. It was not the cause of the problem.

Issue History

Date Modified Username Field Change
2021-05-29 06:45 garyd New Issue
2021-05-30 04:11 garyd Note Added: 0025912