View Issue Details

IDCategoryLast Update
0008596bugs2021-03-02 18:39
ReporterjaboticabaAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionno change required 
PlatformRedhatOSLinuxOS Version(any)
Product Version6.6 
Fixed in Version 
Summary0008596: VST3 - Home/.vst location
DescriptionHi, according to: https://steinbergmedia.github.io/vst3_doc/vstinterfaces/vst3loc.html#linuxlocation
one of the default locations for vst3's is in $HOME/.vst. I've just compiled Surge from source, and it installs locally to that folder. I want to keep my plugins together so they are more portable from one pc to another. Unfortunately, this folder is not one of the default places Ardour looks for vst3 plugins and I can't actually add that folder because the ancient gtk2 file picker does not let you filter for hidden files and folders.

Thanks,
Davis
TagsNo tags attached.

Activities

x42

2021-03-01 22:06

administrator   ~0025574

According to spec it is $HOME/.vst3/ -- not $HOME/.vst/

jaboticaba

2021-03-02 18:16

reporter   ~0025580

Sorry, that's a mistype by me, it is actually in the .vst3 folder not .vst. Anyway, neither are looked at by ardour for vst3's, and no hidden folder can be added by the gtk2 file picker.

x42

2021-03-02 18:21

administrator   ~0025581

Ardour definitely, and unconditionally looks in ~/.vst3/
https://github.com/Ardour/ardour/blob/master/libs/ardour/plugin_manager.cc#L1566

What is your user's $HOME? Does the folder perhaps have usual characters (umlauts or whitespace)?

jaboticaba

2021-03-02 18:39

reporter   ~0025582

Oh, sorry about that, I was looking in the additional vst path's in preferences, it looked like it only looked in two system folders. I had to go to the plugins page and click scan for new plugins to make it appear.

Issue History

Date Modified Username Field Change
2021-02-28 22:26 jaboticaba New Issue
2021-03-01 22:06 x42 Note Added: 0025574
2021-03-01 22:06 x42 Assigned To => x42
2021-03-01 22:06 x42 Status new => resolved
2021-03-01 22:06 x42 Resolution open => no change required
2021-03-02 18:16 jaboticaba Note Added: 0025580
2021-03-02 18:21 x42 Note Added: 0025581
2021-03-02 18:39 jaboticaba Note Added: 0025582