View Issue Details

IDCategoryLast Update
0008553bugs2021-03-13 00:10
ReporterCTSAssigned To 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformArchOSLinuxOS Version(any)
Product Version6.5 
Fixed in Version 
Summary0008553: Resizable JUCE-based Linux VST3 plugin GUI extremely laggy & high CPU
DescriptionWhen I open a JUCE based VST3 plugin with a resizable GUI, Ardour gets very slow and CPU is spending a lot of time doing something to do with resizing. GUI takes several seconds to respond to mouse events (i.e. moving faders is very painful).

As soon as I remove "setResizable(true, true)" from the JUCE plugin editor constructor and just have a fixed size GUI - Ardour handles it without issue.

Here is a stack trace from GDB while the plugin GUI was stuck in "resizing hell":
https://pastebin.com/yCCrrHDG

A lot resizing seems to be happening in response to non-resizing events like mouse clicks on sliders and such.
Steps To Reproduce1. Build a JUCE plugin with "setResizable(true, true)" in the PluginEditor constructor. I can make an example repo if that's helpful.
2. Run Ardour, add the plugin to a track
3. Open the plugin GUI. Do not attempt to resize the GUI - just try moving some sliders!
TagsNo tags attached.

Activities

CTS

2021-02-27 21:05

reporter   ~0025570

Hey there - I just added a PR that I believe fixes this issue.
https://github.com/Ardour/ardour/pull/599

CTS

2021-03-13 00:10

reporter   ~0025598

JUCE team fixed this: https://github.com/juce-framework/JUCE/commit/d4e802016aac5436abbbdd82314a29e061aa193a

Issue History

Date Modified Username Field Change
2021-01-25 08:33 CTS New Issue
2021-02-27 21:05 CTS Note Added: 0025570
2021-03-13 00:10 CTS Note Added: 0025598
2021-03-13 00:10 CTS Status new => closed
2021-03-13 00:10 CTS Resolution open => fixed