View Issue Details

IDProjectCategoryView StatusLast Update
0008540ardourbugspublic2021-01-14 17:06
Reporterzettberlin Assigned To 
Status newResolutionopen 
PlatformDebian GNUOSLinuxOS Version(any)
Product Version6.5 
Summary0008540: ACE EQ crashes Ardour when opening GUI
DescriptionI used ACE EQ successfully in a project including its GUI.
In the very same project it crashed Ardour after inserting a new instance in the master channel, when I tried to open its GUI(double click in the mixer strip).
After this happened, ACE EQ crashed a very new project also, that I had set up to test the problem.
But in that new project, Ardour crashes as soon as I try to insert the ACE plugin.
Inserting other ACE (compressor)works but also crashes as soon as I attempt to open the GUI.
Steps To ReproduceOpen project
insert ACE EQ:

HOST BG COLOR RGBA: 0x3d3d3dff
doublebuffered rendering available
GLX-Version 1.4
The program 'ardour-6.5.0' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 22 error_code 2 request_code 151 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Speicherzugriffsfehler (Speicherabzug geschrieben)

I ran ardour6 with that --sync option BTW

Additional InformationThe only faint hint I could give is, that I tried to inster a Harrison Plugin while working on the first session, got some Message, no success with the Harrison and so I moved on.
As far as I remember, I used the ACE EQ GUI before that attempt on Harrison successfully, I cannot tell, if I did so after too...

I do this with the latest official release from
In Ubuntu Studio 20.4.1 LTS

Test project is attached.
TagsACEplugins, ardour6



2021-01-13 22:47


instant.xml (1,643 bytes)


2021-01-13 23:14

reporter   ~0025415


All xt-* Harrison plugins do crash the project as well... at instert in the mixerstrip


2021-01-14 00:04

administrator   ~0025416

That smells like an OpenGL issue. - Which graphics card and driver are you using?

Can you load them after disabling Preferences > Plugins > Automatically open the plugin GUI when adding a new plugin ?


2021-01-14 00:33

reporter   ~0025417

I can insert them, when the auto opening of the GUI is disabeled, and they seem to work perfectly OK with the generic builtin GUI

My Graphics is this:

01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)

Running with thr recent proprietary driver.


2021-01-14 10:59

reporter   ~0025419

After restarting the whole machine, the GUI of ACE EQ works OK, takes a few seconds to load tho.
I also see some lags in the transport animation, when their GUI is open.
Maybe related: All Plugins from Pere Ráfols Soler (several EQ) do not show their GUI as well...


2021-01-14 17:06

administrator   ~0025420

The latter is a binary incompatibility (gtk2 libs) you have to use binaries from

Issue History

Date Modified Username Field Change
2021-01-13 22:47 zettberlin New Issue
2021-01-13 22:47 zettberlin Tag Attached: ACEplugins
2021-01-13 22:47 zettberlin Tag Attached: ardour6
2021-01-13 22:47 zettberlin File Added: ACETest-2021-01-13-23-13-30.ardour
2021-01-13 22:47 zettberlin File Added: instant.xml
2021-01-13 23:14 zettberlin Note Added: 0025415
2021-01-14 00:04 x42 Note Added: 0025416
2021-01-14 00:33 zettberlin Note Added: 0025417
2021-01-14 10:59 zettberlin Note Added: 0025419
2021-01-14 17:06 x42 Note Added: 0025420