View Issue Details

IDCategoryLast Update
0008528bugs2021-01-02 21:21
ReporterszszokeAssigned To 
Reproducibilityalways 
Status newResolutionopen 
PlatformMicrosoftOSWindowsOS Version10
Product Version6.5 
Fixed in Version 
Summary0008528: Ardour 6.5 crashes after the BOSS GT-1000 is selected as an input and output device in the Audio/MIDI Setup dialog
DescriptionWhen I start a new Ardour 6.5 session
Or I load an existing session and bring up Audio/MIDI Setup Window
And I select the BOSS GT-1000 CORE as Input and Output devices
And I press the Start button
Then the splash screen is visible for about a second
And then Ardour.exe crashes without any
Steps To Reproduce1. Start a new session or open an existing session and bring up the Audio/MIDI Setup dialog
2. Select the BOSS GT-1000 CORE as Input and Output device
3. Press the Start button
Additional InformationI have a Focusrite Scarlett 2i2 2nd Gen that does not trigger the crash.
I tried with both the official 6.5 version and the latest nightly at the time (rev 6.5-63-g3f60d12). The bug can be reproduced in both.

Other BOSS/Roland devices that were tested:
1. BOSS Pocket-GT - reproducible
2. BOSS SY-300 - reproducible

Multiple USB ports and USB cables were tested and made no difference to the outcome.

I do not own any other ASIO compatible devices that I could use for testing.
TagsNo tags attached.

Activities

szszoke

2020-12-30 19:42

reporter  

Ardour-debug.log (38,195 bytes)

szszoke

2020-12-30 19:47

reporter   ~0025366

I forgot to mention that I was using the PortAudio audio system.

szszoke

2020-12-30 19:51

reporter   ~0025367

Ableton Live 10 Lite has no issues using the GT-1000 CORE so I am quite confident that at least the USB connection and drivers are working.

szszoke

2020-12-30 19:54

reporter   ~0025368

The bug cannot be reproduced if I use the MME driver instead of ASIO but that is not desirable because the different channels of the GT-1000 appear as different audio devices and I can only select one input/output.

szszoke

2020-12-30 20:03

reporter   ~0025369

It seems that enabling buffered IO prevents the crash from happening.

szszoke

2021-01-02 21:21

reporter   ~0025372

While there is a workaround for this bug, I think an error message would be better instead of a crash.

Issue History

Date Modified Username Field Change
2020-12-30 19:42 szszoke New Issue
2020-12-30 19:42 szszoke File Added: Ardour-debug.log
2020-12-30 19:47 szszoke Note Added: 0025366
2020-12-30 19:51 szszoke Note Added: 0025367
2020-12-30 19:54 szszoke Note Added: 0025368
2020-12-30 20:03 szszoke Note Added: 0025369
2021-01-02 21:21 szszoke Note Added: 0025372