View Issue Details

IDCategoryLast Update
0008449bugs2020-11-11 18:12
Reportertristan.tarrantAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformUbuntuOSLinuxOS Version(any)
Product Version6.3 
Fixed in Version 
Summary0008449: "Multiple meter definitions found" error on loading session with tempo map imported from a MIDI file
DescriptionImporting into a session a specific MIDI file's tempo map which includes some tempo/meter changes causes Ardour to fail loading the session with an error message.
Steps To Reproduce1. Create a new empty session
2. Import this MIDI file: http://web.tiscali.it/midi_land/midifiles/midifiles_film_tv/profondo_2.mid (also attached) including its tempo map
3. Save the session
4. Open the session again

A dialog box is shown with the following error
Session "..." did not load successfully:
Cannot initialize session/engine: Invalid or corrupt session state.

---ERROR: Could not set session state from XML
ERROR: Multiple meter definitions found at 473
TagsNo tags attached.

Activities

tristan.tarrant

2020-10-21 06:53

reporter  

profondo_2.mid (40,495 bytes)

x42

2020-10-22 15:06

administrator   ~0025142

Last edited: 2020-10-22 15:07

View 2 revisions

This looks like a corrupt MIDI file. Ardour should probably refuse to load it. Where did you get this file from, do you know what software was used to create it?

$ midicomp  profondo_2.mid 
MFile 0 1 480
MTrk
0 TimeSig 4/4 24 8
0 Meta SeqName "PROFOND ROSSO / GOBLIN                  (for SC88/VL/PRO/M-GS64)"
0 Meta SeqName "(C)1997 studio i.e.[ai i:]                                                                music by Simonetti                     Pignatelli                    Martino                                                                                                                                                                                                 "
Error: unexpected running status


tristan.tarrant

2020-10-22 15:32

reporter   ~0025144

Unfortunately I have no idea. And I agree that Ardour should either refuse to load it (probably easier) and definitely refuse to save something it cannot load.

x42

2020-11-11 18:12

administrator   ~0025216

Fixed in 6.3-307-gd3eab4e309.

The issue is that the MIDI file contains a metrum change in the middle of a bar. This is not possible in music notation and caused ardour's tempo-map to go haywire.
The meter-change is now ignored. On the upside, that change happened at the end of the given file, so for the case at hand it's not a big issue.

Issue History

Date Modified Username Field Change
2020-10-21 06:53 tristan.tarrant New Issue
2020-10-21 06:53 tristan.tarrant File Added: profondo_2.mid
2020-10-22 15:06 x42 Note Added: 0025142
2020-10-22 15:07 x42 Note Edited: 0025142 View Revisions
2020-10-22 15:32 tristan.tarrant Note Added: 0025144
2020-11-11 18:12 x42 Assigned To => x42
2020-11-11 18:12 x42 Status new => resolved
2020-11-11 18:12 x42 Resolution open => fixed
2020-11-11 18:12 x42 Note Added: 0025216