View Issue Details

IDCategoryLast Update
0008407bugs2020-09-16 14:49
ReporterjanislAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformGNUOSLinuxOS Version(any)
Product Version 
Fixed in Version 
Summary0008407: Failure to identity some instruments with lv2 1.18
DescriptionArdour checks if a plug-in is an instrument by checking if category is "Instrument". In lv2 library version 1.18 it was changed to "Instrument Plugin" and as a result the check fails. The socond check works for many plugins, but some fail that one too because they have audio inputs, in particular LSP samplers and Surge. In code there are similar checks for utility and analyser plugins that will have the same issue.
TagsNo tags attached.

Activities

x42

2020-09-16 14:49

administrator   ~0025034

Fixed in 6.3-24 c01b7b7842

Issue History

Date Modified Username Field Change
2020-09-14 13:43 janisl New Issue
2020-09-16 14:49 x42 Assigned To => x42
2020-09-16 14:49 x42 Status new => resolved
2020-09-16 14:49 x42 Resolution open => fixed
2020-09-16 14:49 x42 Note Added: 0025034