View Issue Details

IDProjectCategoryView StatusLast Update
0008406ardourbugspublic2021-01-20 12:51
Reporterunfa Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
PlatformArchOSLinuxOS Version(any)
Product Version6.3 
Summary0008406: Exporting a 1-second long audio region takes about 10 minutes
DescriptionWhile working around the problems I've reported elsewhere (, I've stumbled upon another issue.

Exporting an audio region of about 1-second when there's no processing applied takes hundreds of times longer than it should.

I can make my sounds, but I can't deliver them to the client.
Steps To Reproduce1. Right click on an audio region
2. Select "export"
3. Proceed to export the file
4. Wait until Ardour finishes
5. Realize it took forever.



2020-09-13 21:37


Screenshot_20200913_233255.png (89,868 bytes)   
Screenshot_20200913_233255.png (89,868 bytes)   


2021-01-20 02:07

reporter   ~0025439

I run in to this too, on Ardour 6.5 just downloaded from the ardour site, Debian stable, Xfce, Full version from about dialog: Ardour 6.5.0 "Old Land" (rev 6.5) 64-bit Intel.
(I do run into the same problem when using the older Ardour from the Debian repositories).
This is on Jack, with a Behringer U-Phoria UMC204HD. If you need more / other info that can help to solve this, feel free to ask.


2021-01-20 02:22

reporter   ~0025440

And just a little bit later I manage to export sound just fine. This newer version of Ardour have a rearranged Sound/MIDI-installation dialog (Sorry if I get the name wrong, I am translating from the Swedish user interface) - I believe I had the Device setting wrong, and when I set it to the UMC204HD 192k, the sound export started working just fine.


2021-01-20 10:36

administrator   ~0025441

1) Can you reproduce this without JACK (Menu > Window > Audio/MIDI Setup)?
2) Is it the export by itself that takes this long, or start/end of he export?
3) Could it be that the export target is a slow USB disk or thumbdrive?


2021-01-20 12:51

reporter   ~0025442

@x42 - Changing from JACK to Alsa or Pulseaudio doesn't affect it, now it works just fine disregarding what is selected.

Unfortunately I cannot find the setting which causes the problem again - the export works just fine.

Most of the time the export just wrote 42 bytes to the file, and then simply paused. I experienced it as if it was completely stuck, but sometimes I managed to get a file that represented parts of the track in ardour, something like 1.4 MB, for a 18 sek clip.

For your question 3, the answer is no. When using ardour I have written the file to a M.2 SSD.

Earlier it would get stuck exactly as in the image unfa provided above ^.

Issue History

Date Modified Username Field Change
2020-09-13 21:37 unfa New Issue
2020-09-13 21:37 unfa Tag Attached: export
2020-09-13 21:37 unfa File Added: Screenshot_20200913_233255.png
2021-01-20 02:07 gusnan Note Added: 0025439
2021-01-20 02:22 gusnan Note Added: 0025440
2021-01-20 10:36 x42 Note Added: 0025441
2021-01-20 12:51 gusnan Note Added: 0025442