View Issue Details

IDProjectCategoryView StatusLast Update
0008344ardourbugspublic2022-12-11 14:21
Reporterapoorv569 Assigned Topaul  
Status resolvedResolutionno change required 
PlatformArch LinuxOSGNU/LinuxOS VersionArch Linux
Product Version6.2 
Summary0008344: Unable to launch Ardour.
DescriptionI was working on a project a day before yesterday, and everything was fine, but today when I tried to open Ardour, nothing opened, tried a couple of more time and nothing showed up. So I tried opening from a terminal to if it outputs some error, it gave some warning about gtk murrine engine not found, so I installed it, and then I tried again and it gets stuck here
[apoorv@Apoorv-PC ~]$ ardour6
Ardour6.2.0 (built using 6.2 and GCC version 10.1.0)
Ardour: [INFO]: Your system is configured to limit Ardour to 524288 open files
Ardour: [INFO]: Loading system configuration file /etc/ardour6/system_config
Ardour: [INFO]: Loading user configuration file /home/apoorv/.config/ardour6/config
Ardour: [INFO]: CPU vendor: GenuineIntel
Ardour: [INFO]: AVX-capable processor
Ardour: [INFO]: CPU brand: Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz
Ardour: [INFO]: Using SSE optimized routines
Ardour: [INFO]: Loading plugin meta data file /usr/share/ardour6/plugin_metadata/plugin_tags
Ardour: [INFO]: Loading default ui configuration file /etc/ardour6/default_ui_config
Ardour: [INFO]: Loading user ui configuration file /home/apoorv/.config/ardour6/ui_config
Ardour: [INFO]: Loading 449 MIDI patches from /usr/share/ardour6/patchfiles
Ardour: [INFO]: Loading color file /usr/share/ardour6/themes/caineville-ardour.colors
I tried waiting for about 15-20 mins nothing happens. I tried removing Ardour and reinstalling again, no luck. After a long time trying to fix it, I gave up and formatted my drive and reinstalled my Arch Installation, after finishing installation, I installed Ardour and tried running it ran fine, but after installing all the other packages that I use on my PC, I rebooted and tried running Ardour, again nothing happens, tried running through terminal still stuck on the same output as I posted above.

One thing if I try to run it as root, it does open.
TagsNo tags attached.


duplicate of 0005605 closedx42 Hangs while starting at loading UI config files 



2020-07-31 12:27

administrator   ~0024872

That smells like a duplicate of (your user's desktop theme defines colors and conflicts)

   export GTK2_RC_FILES=/usr/share/themes/Adwaita/gtk-2.0/gtkrc
or maybe
   export GTK2_RC_FILES=/nonexistent
before starting Ardour


2020-07-31 12:44

reporter   ~0024873

@x42 I tried running both commands, no luck. Still stays stuck there in the terminal.


2020-07-31 13:53

reporter   ~0024876

@x42 Well, I tried changing my GTK theme to Adwaita, its opening now. Does it means I won't be able use the theme I want?


2022-12-11 01:10

administrator   ~0027013

Ardour doesn't really use your system theme anyway.


2022-12-11 11:21

reporter   ~0027021

I posted another duplicate of this in the forum:
Maybe my workaround helps you.


2022-12-11 11:30

reporter   ~0027022

Ah, GTK2_RC_FILES=/nonexistent works as well. It's probably the better workaround.


2022-12-11 11:39

reporter   ~0027023

One can also put the workaround in ardour's .desktop file:
`Exec=ardour7` -> `Exec=bash -c 'export GTK2_RC_FILES=/nonexistent && ardour7'`

Issue History

Date Modified Username Field Change
2020-07-31 10:44 apoorv569 New Issue
2020-07-31 12:27 x42 Note Added: 0024872
2020-07-31 12:44 apoorv569 Note Added: 0024873
2020-07-31 13:53 apoorv569 Note Added: 0024876
2022-12-11 01:10 paul Assigned To => paul
2022-12-11 01:10 paul Status new => resolved
2022-12-11 01:10 paul Resolution open => no change required
2022-12-11 01:10 paul Note Added: 0027013
2022-12-11 11:21 groudsquirrel Note Added: 0027021
2022-12-11 11:30 groudsquirrel Note Added: 0027022
2022-12-11 11:39 groudsquirrel Note Added: 0027023
2022-12-11 14:21 x42 Relationship added duplicate of 0005605